All I wanted was to use an umlaut here and there in my paper, so I loaded the above package. I still did not get a decent umlaut. Since I saw that german was popping up in places where it shouldn't have (such as Beweis instead of Proof), I deleted the include line of the package in the .tex file. But now I have an even bigger problem:

Package babel Error: Unknown language `german'. Either you have (babel) misspelled its name, it has not been installed, (babel) or you requested it in a previous run. Fix its name, (babel) install it or just rerun the file, respectively.

Now I don´t even care about the umlauts, I just want everything to go back to normal. I do not understand what I am supposed to do. I certainly do not want to reload the package.

  • Welcome to TeX.SX! Is your input encoding correct? – user31729 Nov 4 '14 at 11:39
  • Simply ignore the babel error and continue the compilation. Next time it will be gone. (babel has nothing to do with umlauts, you need the correct inputenc option for this). – Ulrike Fischer Nov 4 '14 at 11:43
  • \usepackage[utf8]{inputenc} should do the job – user31729 Nov 4 '14 at 11:57
  • 1
    "Beweis" is because you've set German as your default language. Try \usepackage[german, english]{babel} (or whatever the correct name of the German-language option in babel is); the last listed language will be the document default, so strings like "Proof" will be in it. Of course, if all you want are a few umlauts, babel is probably overkill; just do \"u (or the appropriate letter) when you need one. – dgoodmaniii Nov 4 '14 at 14:01

What do you mean with "I deleted the package"? Did you remove the \usepackage{babel} line, or did you remove the package files from your hard disk?

By the way, in order to get an umlaut without loading a package you can use e.g. \"u and \"a for ü and ä, respectively.

Maybe you have a left-over .aux file. If so, try to remove it and rerun LaTeX again.

  • OK, does the problem persist after removing any remaining .aux files and rerunning LaTeX? – ph0t0nix Nov 4 '14 at 12:22
  • The problem went away, but for some reason \''u does not work. So, I had to use $\ddot{u}$ in the middle of someone's name. – Andrew Chiriac Nov 5 '14 at 12:35
  • It looks like you used two single quotes after the slash: \ ' ', but it should be a double quote: \ " (without the extra spaces, of course, I just added those for clarity). – ph0t0nix Nov 5 '14 at 12:37
  • You are right. It works now. I guess two single quotes do not equal one double quote. – Andrew Chiriac Nov 5 '14 at 15:02

This error occurs somethimes, if the used encoding of the editor and the used encoding in the LaTeX file are not the same.

With the following MWE

\documentclass[11pt,english,german]{article}  % ngerman
\usepackage[utf8]{inputenc}                   % latin9 utf8
\usepackage[german]{babel}                    % german, ngerman, english
\usepackage{blindtext}        % prints dummy text in different languages


\Blinddocument               % create dummy document here


the editor TeXnicCenter shows the following screen:

Part of screen of TeXnicCenter

In the right corner below you can see the encoding (UTF-8) the editor is using. If the encoding in the tex file (command \usepackage[utf8]{inputenc}) is the same the error vanished (see log part in screenshot).

Just a remark: german uses the old german writing rules, if you want the newer one please use ngerman.

Hope this helps you for a better understanding of the encoding problem ...

  • The funny thing is that I'm not even using an editor. But anyways, the problem somehow went away on its own. – Andrew Chiriac Nov 5 '14 at 12:33
  • I guess I do not know exactly what an editor is. I just downloaded MikTeX2.9 and I type all my equations by hand. – Andrew Chiriac Nov 5 '14 at 15:09

For me (using TexStudio) the solution was to add german in the \documentclass options and delete the command \usepackage[german]{babel}

It Works:



It doesn't:


  • In this way you don't load babel at all, and you'll get a complaint about the unused global option. You say this was the solution for you but it's not very clear to what this should be a solution. – campa Apr 15 at 14:32
  • @campa Well, I couldn't load babel, but I had a similar effect. The names of the document elements, e.g., equations, where translated into German. – loved.by.Jesus Apr 15 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.