2

I am writing a humanities work in book format with LyX 2.1.2 in Linux Mint 17. I need text output in PDF format in an English language document with a few occasional words in Greek, and Hebrew.

I managed to successfully export in pdflatex the English and Greek text correctly, because the document language is English, and the entire Greek alphabet is available from Insert/Special Character/Symbols (clumsy but works). However there are only four (4) Hebrew letters available as Symbols (How do you add the entire Hebrew alphabet to the Symbols?).

If I switch to a Hebrew keyboard, I can enter all of the characters I need into the LyX editor, but when I try to export the result into pdf, LyX can not recognize the Hebrew letters I typed into my text. LyX does recognize and export to pdf the four Hebrew letters available in the Symbols menu.

In other words, how can I input more than only the 4 available Hebrew characters available as "Special Characters" under "Input".

Please be descriptive in your answer (eg. I can copy your scripts into my document), because I am a noob in LaTeX.

1

A relatively simple solution is to use XeLaTeX to typeset unicode characters directly. That way you will have your foreign language characters in their native script in LyX. The key is to turn on "Use non-TeX fonts (via XeTeX/LuaTeX) in the "Fonts" tab of your document's settings.

See my answer to Two fonts for two languages using lyx where I provide a sample LyX document.

Copy the example, paste it into a new text document and save it with a .lyx extension using a plain text editor, then open the saved file in LyX.

To enter foreign text you can copy and paste from other sources, e.g. web pages, set up an appropriate (Hebrew) keyboard, or copy and paste from an app like "Character Map".

  • Your solution worked better than I had hoped for, giving total freedom of entry of Greek and Hebrew text into my English LyX document. – Vilis Lietuvietis Nov 5 '14 at 15:38
  • I'm pleased it worked so well for you – penguinpreferred Nov 5 '14 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.