3

Is the Antibes theme the problem here? according to this post, the solution I put in my MWE (below) should do the trick but it doesn't. This answer doesn't work either. I got no error whatsoever, it just compiles flawlessly but it outputs only one slide. It should give three slides with the same page number (ie. 1/1). It's the same if I use Boadilla theme.

Any idea how to get the right output? thanks in advance for your support on this,

MWE:

ps. I just left these packages to check that there was no conflict. I did several tests after commenting one by one and it seems that they are causing no problems at all.

\documentclass[compress,final]{beamer}

\usetheme{Antibes}
    \setbeamertemplate{footline}[page number]
    \setbeamercovered{transparent=25}
    \setbeamertemplate{navigation symbols}{}
\usecolortheme{dolphin}

\usepackage{lmodern}
\usepackage{graphicx}
\usepackage[framemethod=tikz]{mdframed}
\usepackage{fixltx2e}
\usepackage{textcomp}
\usepackage{textpos}
\usepackage{tikz}
\usepackage{etoolbox}

%\makeatletter
%\def\c@slideinframe{\beamer@slideinframe}
%\makeatother

\newcounter{multipleslide}

\makeatletter%
\newcommand{\multipleframe}{%
    \setcounter{multipleslide}{\value{framenumber}}
    \stepcounter{multipleslide}
    \patchcmd{\beamer@@tmpl@footline}% <cmd>
    {\insertframenumber}% <search>
    {\themultipleslide}% <replace>
    {}% <success>
    {}% <failure>
}
\newcommand{\restoreframe}{%
    \patchcmd{\beamer@@tmpl@footline}% <cmd>
    {\themultipleslide}% <search>
    {\insertframenumber}% <replace>
    {}% <success>
    {}% <failure>
    \setcounter{framenumber}{\value{multipleslide}}%
}
\makeatother%

\begin{document}

\section{ITEM}
\subsection{item}
\multipleframe
\begin{frame}[allowframebreaks]
    \begin{itemize}
        \item<1-> item 1
        \item<2-> item 2
        \item<3-> item 3
    \end{itemize}
\end{frame}
\restoreframe

\end{document}

enter image description here

  • remove option "alowframebreaks". Slides will be numbered 1/1, 2/1 and 1/3. – Zarko Nov 5 '14 at 18:42
  • removing [allowframebreaks] produces the 3 slides but with 1/3, 2/3, 3/3, and it should be 1/3 for every slide, any idea what the problem is? – Gery Nov 5 '14 at 18:48
  • Maybe it's frame number rather than page number? – egreg Nov 5 '14 at 19:14
  • @egreg thanks! that was the problem, indeed, I confirm that I don't need the solutions I was trying, simply using frame number did the trick. If you put that as answer, I'll mark it as such. Thanks again. – Gery Nov 5 '14 at 20:42
2

In beamer, page number refers to the “physical” page number: any overlay increments the number.

You want to use frame number, that's incremented by \begin{frame}.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.