6

When I compile a pdf document in texmaker, I often press Alt+Tab to swich to the external pdf viewer.

If at that point the cursor in texmaker is by coincidence at a position where texmaker can make an auto-completion, pressing Alt will show the options for auto completion, pressing Tab will highlight the first option and releasing both will select the first option.

This can be very anoying when the cursor is in the middle of a complicated formular. Is there a way to prevent texmaker to missunderstand the Alt-Tab command without swiching off auto-completion completely? I am using Texmaker 4.1 on Ubuntu 14.4 LTS.

3

TexMaker is hard-coded to use typable keys to activate auto-completion, e.g., any character key including {}[](), etc.. However, there is a bug, it took ALT key as one of typable keys which is wrong.

For now, the only work-around is to turn off auto-completion. It's in Options-> Configure TexMaker->Shortcuts.

  • It's actually in: Options-> Configure TexMaker->Editor, and you have to untick "completion" – Elliott Smith Apr 2 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.