33

For some pdf ebooks, Adobe Reader displays the cover page alone even though the display mode is "two page view". Other than the cover page, the rest of the pdf content is displayed as two pages at once, which is expected in the "two page view" mode.

My question is: Is it possible to enforce this behavior if I use pdflatex, and if so, how could I achieve that? The document class I'm using is memoir.

  • I think, in my experience, that this is something classical once you use a two-side option for classes that proposes them. – Martigan Jun 18 '11 at 17:11
  • 8
    I think this is an Adobe feature. You can activate this behaviour in View->Page Display->Show Cover Page During Two-Up. – Gonzalo Medina Jun 18 '11 at 17:31
  • I'd strongly recommend, unless this is just a convenience for yourself, that you do not try to second-guess the ways in which your readers will want to read the book. Some might even be offended at being put into two-page-spread mode... – Brent.Longborough Nov 24 '12 at 16:38
35
\usepackage[pdfpagelayout=TwoPageRight]{hyperref}

If you cannot use hyperref for some reason, use \pdfcatalog{/PageLayout /TwoPageRight}.

Adobe Reader will only pay attention to this setting if in preferences, on the "Page Display" tab you set the "default layout and zoom" to have "Page layout: Automatic".

This is what it looks like in an MWE:

\documentclass{book}
\usepackage[english]{babel}
\usepackage{blindtext}
\usepackage[pdfpagelayout=TwoPageRight]{hyperref}
\author{Me}
\title{This}
\begin{document}
\maketitle
\Blinddocument
\end{document}

screen shot

  • What about other PDF readers than Adobe Reader? It seems it doesn't work for me with Evince in Ubuntu. – presenter Nov 9 '17 at 15:17
5

I Know the answer: Just navigate Adobe Acrobat "View" menu, then select "Page Display"--> "Show Cover Page In Two Page View"

But first make sure you follow this one (link below)

http://indesignsecrets.com/make-it-look-like-a-book-in-the-acrobat-pdf.php

  • 1
    We like this site to be self-contained. While references to external sites are okay, it's always best IMO to include this content fully, with a link to the reference. Otherwise, if the link provided fails, this post becomes useless. – Werner Nov 24 '12 at 16:25
  • 1
    And how does one enforces this from a PDF? – Martin Schröder Nov 24 '12 at 16:29
3

I don't think you have to do anything special in TeX. This is probably a PDF reader specific problem. Below is a screenshot of a document I am working on, displayed in Preview on Mac OS X. If I understand correctly, this is the behavior you are expecting.

Two page view

For this document I didn't do anything special in TeX at all.

So perhaps there are some settings in Adobe reader to enforce this behavior.

  • This is actually a problem with Preview: it simply doesn't give a choice, nor does it obey initial view settings stored in the PDF. Adobe Reader does and so does Skim. – Szabolcs Aug 23 '13 at 15:22
1

I would always like to be able to scroll trough the document, and I can imagine that everyone does. Also, even though it is of always possible to manually change the view settings in adobe reader itself, we don't really want to do that. That is why I am adding this answer, which also works in the memoir class.

I think it is best to use the TwoColumnRight option of the hyperref package. This forces the adobe reader setting View > Page Display > Two page scrolling. See the MWO below:

\documentclass{memoir}
\usepackage[pdfpagelayout=TwoColumnRight]{hyperref}
\usepackage{blindtext}
\author{Author}
\title{Title}
\begin{document}
\maketitle
\Blinddocument
\end{document}

scrollable twopage pdf file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.