3

I try to plot a large spectrum with pst-plot, but I cannot create a psgraph environment large enough, because the x-axis line is not drawn correctly.

Do you know how to make it work?

% !TeX program = xelatex
\documentclass[paper=A3,paper=landscape]{scrartcl}
\usepackage{pst-plot}
\usepackage[pass]{geometry}
\begin{document}
\psset{linewidth=0.1pt}
\begin{psgraph}(0,0)(10,10){20cm}{20cm}
\end{psgraph}
\end{document}

enter image description here

1

At the time I am writing this answer, PSTricks does not support hexadecimal number 2a0 in your {2a0cm}. So you need to remove the a as follows.

% !TeX program = xelatex
\documentclass[paper=A3,paper=landscape]{scrartcl}
\usepackage{pst-plot}
\usepackage[pass]{geometry}
\begin{document}
\psset{linewidth=0.1pt}
\begin{psgraph}(0,0)(10,10){20cm}{20cm}
\end{psgraph}
\end{document}
| improve this answer | |
  • The a was accidentially there. I edited the post. – Niklas Nov 12 '14 at 18:34
1

I cannot see this with up-to-date TL 2016. It looks like that you have a unit setting elsewhere ...

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.