2

I've downloaded MacTex along with TexStudio, and now I've spent several days trying to make it compile Russian texts. It seems, I've tried every single type of sudo command mentioned on this site without considerable results. Now I work with this preamble, e.g.:

\documentclass{article}
\usepackage[T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english, russian]{babel}

\begin{document}
Помогите мне {\it прошу вас} {\bfseries пожалуйста}

\end{document}

This ends up with

Font T2A/cmr/m/it/10=lati1000 at 10.0pt not loadable: Metric (TFM) file not found...
Font T2A/cmr/bx/n/10=labx1000 at 10.0pt not loadable: Metric (TFM) file not found...

So I assume all of the problems occur as I try to make something either bold or italic or switch the documentclass to book. And I'm sort of afraid of even thinking about integrating hyper references or specific chapter numerations. As I am new to Mac all along, please-please treat me as the dumbest person, specifying each and every step. But any help will do.

Thanks in any case

closed as unclear what you're asking by egreg, TeXnician, Moriambar, Stefan Pinnow, lockstep Jun 5 '17 at 8:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do you have cm-super installed? – Bernard Nov 8 '14 at 13:09
  • If you have installed the full MacTeX there should be no problem, because the missing TFM files are generated on the fly. Can you start a Terminal window and type which pdftex followed by return? What's the shown output? – egreg Nov 8 '14 at 13:40
  • @Bernard Tex Live tells me that I have – Maralex Nov 9 '14 at 12:18
  • @egreg The output is "/usr/texbin/pdftex". It appears to me that the main problem is TexStudio itself, as TexShop managed to make a pdf out of it. If so, could you perhaps advise some other editor? Btw, TexShop totally ignores some changes, as, for instance, \titleformat{\subsubsection}{\normalfont\fontsize{12}{17}\itshape \bfseries}{ \thesubsubsection }{1em}{}... Still don't know how to deal with them – Maralex Nov 9 '14 at 12:27
  • My guess is that TeXStudio has wrong paths for the programs. Check in the preferences if pdflatex is preceded by /usr/texbin or something else – egreg Nov 9 '14 at 12:41
0

Install the cmsuper fonts:

\documentclass{article}
\usepackage[T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english, russian]{babel}

\begin{document}
Помогите мне {\it прошу вас} {\bfseries пожалуйста}

\sffamily
Помогите мне {\it прошу вас} {\bfseries пожалуйста}

\end{document}

enter image description here

  • How should this solve the problem? The first line still uses lati1000 and labx1000. – egreg Nov 8 '14 at 15:53
  • no, it uses SFxx1000 ... – user2478 Nov 8 '14 at 17:24
  • In output, yes. But the OP's problem is that the TFM files are not generated, so the output won't be generated in the first place. – egreg Nov 8 '14 at 18:09
  • the t2alm* are missing or at least in the wrong place. However, Latin Modern ha no cyrillic characters. cmsuper has the t2a encoding files. – user2478 Nov 9 '14 at 8:44
  • You're confusing the levels. The font definition files don't belong to cmsuper, which just has Type1 fonts and, indeed, t2acmr.fd that's loaded by that example file, belongs in .../tex/latex/cyrillic. The file t2almr.fd has nothing to do with Latin Modern, but is not loaded anyway. Note that if t2acmr.fd was misplaced or missing, LaTeX would have no clue about the need of lati1000.tfm or labx1000.tfm. – egreg Nov 9 '14 at 10:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.