1

I found that spell check does not applied for frame title in beamer. It spell checks every thing else except those titles.

For example: below the word "Literature" is written wrong, however, on TeXstudio the one on the title is not market with the usual underline red line to indicate the spelling is incorrect. And the one in the content of the frame is marked as not correct.

\documentclass[11pt]{beamer}
\usetheme{default}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\begin{document}
    \maketitle

    \begin{frame}{Lurtrature}
        Lutrature
    \end{frame}
\end{document}

I am on Mac OS 10.10 and TeXstudio 2.8.4

  • Welcome to TeX.SX! Please add a minimal working example (MWE) to make your question more clear. – Pier Paolo Nov 8 '14 at 18:58
  • @PierPaolo I have updated the question with an example. – salhin Nov 8 '14 at 19:37
  • Spellchecking is a feature of your editor, in this case TeXstudio, not the beamer class. You might want to edit your question to make it clear that this is really an issue with TeXstudio's spellchecker. I'm tagging @Tim Hoffmann, one of the authors of TeXstudio, which might also help... – Jason Zentz Nov 9 '14 at 2:25
1

There is only limited support for spell checking within LaTeX command options. TXS needs to know if an option should be checked. So far, it is only possible to define this for single-argument commmands like \textit{}. Spellchecking in the second argument of \begin{frame}{Lurtrature} is not supported.

For more information the section on spellchecking in the manual as well as the description of the cwl format (particularly section 4.13.2. Argument Names). There's also a feature request concerning the possible extension of the cwl format.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.