3

I am using

\documentclass[journal,12pt,draftclsnofoot,onecolumn]{IEEEtran}

However, I find the caption font size of figures and tables is much smaller than the context. Does anyone know how to solve this problem?

1
  • 1
    The IEEEtran class uses the format IEEE wants for its publications. – egreg Nov 8 '14 at 23:57
5

It is not a problem, it is a feature specific for the IEEE journals. The IEEEtran class was specifically designed to use this formatting for its captions, so it would be not a good idea to override this if you are planning to submit your document to a IEEE journal. That being said, you can change the setting by patching the internal \@makecaption to suppress the \footnotesize switch used by the class; given the implementation of this command, with your settings, you will need to patch the command four times:

\documentclass[journal,12pt,draftclsnofoot,onecolumn]{IEEEtran}
\usepackage{etoolbox}

\makeatletter
\patchcmd{\@makecaption}
  {\footnotesize}{}{}{}
\patchcmd{\@makecaption}
  {\footnotesize}{}{}{}
\patchcmd{\@makecaption}
  {\footnotesize}{}{}{}
\patchcmd{\@makecaption}
  {\footnotesize}{}{}{}
\makeatother

\begin{document}

\begin{figure}
\centering
A
\caption{A test caption for a figure}
\end{figure}
\begin{table}
\centering
B
\caption{A test caption for a table}
\end{table}
Some regular text

\end{document}

The result:

enter image description here

2
  • Or \xpatchcmd*{\@makecaption}{\footnotesize}{}{}{} with regexpatch; just for information. – egreg Nov 9 '14 at 0:36
  • @egreg OK. Then, I guess, if you agree, we can clean up our comments and leave just your first one. – Gonzalo Medina Nov 9 '14 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.