I want to print a page with a smaller size than and A4 paper on a A4 size layout and I want to show the crop marks on it. I specify the page and layout size in the geometry package options but as you can see in the MWE, half of the page goes outside of the A4 paper. I am pretty sure I missing some options here.

enter image description here


\usepackage[ layoutheight=297mm,layoutwidth=210mm,paperheight=197mm,paperwidth=130mm,showframe=true,showcrop=true]{geometry}




enter image description here

  • @Mico I edited to show what I want. I want the smaller page to be centered in the middle of the A4 paper. But, as you can see, half of the page is gone outside of the A4 paper.
    – enthu
    Commented Nov 9, 2014 at 7:38
  • Thanks. I'll post a solution that uses the parameters layoutvoffset and layouthoffset.
    – Mico
    Commented Nov 9, 2014 at 7:39
  • @Mico thank you very much... I have been working on the problem for about six continuous hours!
    – enthu
    Commented Nov 9, 2014 at 7:40

1 Answer 1


In the terminology of the geometry package, the paper<*> parameters refer to the physical size of the sheets of paper the document will be printed on. The layout<*> parameters, by contrast, refer to the logical size of the "paper", which will (one hopes) be no larger than the physical size of the sheet of paper. (Put differently, with regard to paper and layout, your terminology and that of the geometry package are exactly reversed...)

You will need to use the parameters layoutvoffset and layouthoffset to indicate where on the physical page the logical page is supposed to be placed. Assuming that the logical page should be centered on the physical page, and given that the differences between the physical and logical dimensions are 100mm and 80mm, respectively, the values of layoutvoffset and layouthoffset should be 50mm and 40mm.

By the way, if the logical page is supposed to be exactly centered on the physical page, you needn't load the crop package; specifying the option showcrop=true (as you already do) suffices.

Addendum, to address the follow-up request to make the text block margins be zero: To make the text block occupy the entire logical layout, while still showing the header and footer lines, you need to specify the options margin=0pt and includeheadfoot when loading the geometry package.

enter image description here


\usepackage[ paperheight  =297mm,paperwidth   =210mm,  % or: "paper=a4paper"
             layoutheight =197mm,layoutwidth  =130mm,
             layoutvoffset= 50mm,layouthoffset= 40mm,
             margin=0pt, includeheadfoot,
             showframe=true, showcrop=true]{geometry}

%% \usepackage[a4,center]{crop}  %% not needed if logical page is centered on physical page

\chapter{In the Beginning}
  • As far as I know you can just say layout=a4paper and omit the paperheight ,paperwidth statements (but not the layoutwidth=... of course)... and you were just a few seconds quicker than me :-(
    – user31729
    Commented Nov 9, 2014 at 7:59
  • @ChristianHupfer I chose this way to show the A4 paper size, because later it would be easier to shift from a portrait to landscape paper.
    – enthu
    Commented Nov 9, 2014 at 8:01
  • @EnthusiasticStudent: The landscape option should help too... and the solution is bascially what I proposed to you yesterday evening in chat ;-)
    – user31729
    Commented Nov 9, 2014 at 8:02
  • @EnthusiasticStudent - Note, incidentally, that I didn't specify any margin options, as you didn't specify any settings in that regard either. You will probably still need to set the top, bottom, left, and right margins -- unless, by some chance, you're satisfied with the default settings.
    – Mico
    Commented Nov 9, 2014 at 8:05
  • @Mico What's the reason for such distance between the crop sign and the corner of the logical page? Is it because of the margins not defined?
    – enthu
    Commented Nov 9, 2014 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .