8

I want to disable auto-complete for braces in TeXstudio. In its simplest form, when I type { I do not want it to automatically add a }. When it does this, many times I end up deleting the brace, which is a hassle. Also, when I hit Ctrl+I to get into italics mode I don't want it to auto-complete the ending brace either. I have gone to Options -> Configure TeXstudio... -> Completion -> Show Advanced Options and disabled everything. But it still auto-completes them.

In case it matters the version I have is TeXstudio 2.8.4.

2
  • Sorry, I thought you are having texworks editor
    – enthu
    Nov 10, 2014 at 17:58
  • haha it's fine. Part of my problem is all the help out there is for different editors/versions. I have edited the post to include the version in case it comes up again.
    – Curtis
    Nov 10, 2014 at 18:01

1 Answer 1

6

Please uncheck "Auto Complete Parentheses". It can be found "Options / configure TeXStudio" (see screenshot). It does work for me under TeXStudio 2.12.14. close parentheses automatically

Edit: as for the shortcut CTRL+I. I don't think there is an easy way to achieve that. You will have to either alter an existing cwl file (where the definitions are stored) or create a new one. Perhaps you can find an answer when you search for the term "custom cwl".

5
  • Thanks that fixed the first part. Any idea on how to have it not auto place the close brace when you do "ctrl-i"?
    – Curtis
    Nov 10, 2014 at 18:08
  • I have edited my answer. Please see above Nov 10, 2014 at 19:14
  • K thanks. Probably not worth the effort then. But you fixed the main issue I had, so thanks a ton :D
    – Curtis
    Nov 10, 2014 at 19:51
  • 1
    Question on Ctrl+I: Go to Macros -> User Macros and create a new normal macro with content \textit{. Then go to Options -> Configure -> Shortcuts and assign Ctrl+I to your new macro. Nov 11, 2014 at 22:14
  • I'd add this as a comment to blue_tiger300's answer but I don't have enough reputation. I was having the same problem (but on TeXStudio version 2.9.4) and I found before I could find the 'close parentheses automatically' option, I had to tick the 'show advanced options' button in the bottom left of the 'configure TeXStudio' dialogue box.
    – user76200
    Apr 14, 2015 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.