2

I need to create a document (I am using TeXworks) that requires the following packages/libraries:

\documentclass[spanish]{article}
\usepackage[activeacute]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{amsmath, amssymb}
\usepackage{tikz}
\usetikzlibrary{arrows,automata,babel}

I can compile it using TeXworks under Windows but whenever I try to do it under Debian Wheezy I get this error message:

! I can't find file tikzlibrarybabel.code.tex'. <argument> ...nput tikzlibrary\pgf@temp .code.tex \catcode\@ =\csname tikz... l.8 \usetikzlibrary{arrows,automata,babel}

What is the easiest way to make it work?

I understand I should be able to put some libraries/packages in the same directory my .tex file is and make it work, but I can't. I have downloaded tikzlibrarybabel.code.tex and put it in the directory but then the error message I get is this one:

(./tikzlibrarybabel.code.tex

! Package pgfkeys Error: I do not know the key '/tikz/handle active characters in code' and I am going to ignore it. Perhaps you misspelled it.

See the pgfkeys package documentation for explanation

  • 1
    i think you don't have tikz 3.00 installed. put \pgfversion to typeset the verion on the document or use \listfiles in the preamble and look at the log fie for the version info – percusse Nov 12 '14 at 18:44
  • My pgf version is 2.10. How should I update it? – D1X Nov 12 '14 at 22:25
  • If you want to use currently updated stuff, by far the best option is to eliminate Debian's TeX Live packages from your system and use upstream's installer to install under /usr/local/texlive. (It won't use directories managed by Debian's package manager. Recommendation: install and manage the upstream installation as a non-root user who isn't you e.g. as a user named texlive or whatever.) – cfr Nov 13 '14 at 0:45
2

You can't use the TikZ library babel unless you have TikZ/PGF version 3.00 (or later).

Installing the new version over an older TeX Live is not recommended. Update your TeX distribution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.