1

I'm trying to set up an Eclipse Environment with TexLipse using XeLaTex which is throwing the following error during "build":

xelatex.exe> ("C:\Program Files\MikTex\tex\latex\polyglossia\gloss-german.ldf"
xelatex.exe> 
xelatex.exe> Package polyglossia Warning: \setlocalhyphenmin useless for unknown language ge
xelatex.exe> rman on input line 6.
xelatex.exe> Package polyglossia Warning: You asked for `ngerman' but only `german'    hyphenat
xelatex.exe> ion is available! on input line 57.

The Tex document look like this:

\documentclass{scrartcl}
\usepackage{polyglossia}
%\setdefaultlanguage[spelling=new,latesthyphen=true,babelshorthands=true]{german}
\setmainlanguage{german}
\begin{document}
...
\end{document}

If I run XeLatex via command line everything works like a charm and a valid pdf is generated. But something doesn't work during the Eclipse TexLipse "build". The definition for the builder in Eclipse is set as xelatex -synctex=1 -interaction=nonstopmode --src-specials %input

Exactly the same line can be used in the command line for a valid generation of a PDF file. Does anybody know what TexLipse is messing up? At least I'm suspecting it for the issue.

  • Welcome to TeX.SX! Surely you have to remove --src-specials, although it's probably not the source of the problem. – egreg Nov 12 '14 at 19:19
  • 1
    My feeling is that the command line and TeXlipse use different TeX distributions. Can you check for the path of scrartcl.cls in the .log file for the two compilations? – egreg Nov 12 '14 at 19:23
  • Thanks for your quick response and the warm welcome here egreg. The version via cmd for the scrartcl.cls seems to be ("C:\Program Files\MikTex\tex\latex\koma-script\scrartcl.cls" Document Class: scrartcl 2013/12/19 v3.12 KOMA-Script document class (article) which is exactly the same as via texlipse. For both runs the --src-specials was removed. – Manu Kast Nov 12 '14 at 19:43
  • Here's the whole log file for the cmd line execution which is wokring Log File and here Log File at line 461 the error occurs. Maybe this helpful. – Manu Kast Nov 12 '14 at 20:05
  • If you look at the start, the log file with TeXlipse says Babel <3.9l> and hyphenation patterns for 0 languages loaded. which becomes Babel <3.9l> and hyphenation patterns for 4 languages loaded. from the command line. So you have a straw xelatex.fmt file somewhere that TeXlipse somehow picks up. – egreg Nov 12 '14 at 20:30
3

I finally found the issue that lead to the problem with your great hints and possible solutions. Thanks for that guys!

Miktex somehow installed some packages e.g. xelatex.fmt in C:\Users\USER\AppData\Local\MiKTeX\2.9\miktex\... directory. This could be arisen from my own fault in the previous installation procedure. Miktex asks for user confirmation to install new missing packages. I probably selected "install for user" and not "install for all users" which led to this situation. When I invoked xelatex from cmd there was no issue occurring because it could find the package in the user directory. Somehow texlipse didn't find it. The reason for that in detail is not clear to me.

I recognized the problem because of your hints to look at the -recorder option and the created .fls file, within different paths were used for the xelatex.fmt file.

To solve the problem I simply deinstalled miktex and reinstalled it for all users - the same I did before. But this time I took care not selecting "install for user" during the package installation of the other missing packages while invoking the first xelatex run. Now there are no files, except some temp files, in the users home directory and everything works perfectly.

Some further hint which could cause access exceptions: I had to grand my user full privileges on the Programm Files\Miktex\ folder to get rid of it. (Maybe this is helpful for other problems too).

So thanks again for your quick help and great tips. I appreciate it very much.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.