1

I am using the IEEE transactions template in lyx and I noticed on the figures instead of saying "Fig.1" or "Fig. 2", the figures are labeled as "Figure 1." or "Figure 2."

I looked at the most recent publications from this journal and the correct method is Fig., not Figure as lyx is outputting.

I am wondering what could be wrong and what I should try. I already went to Document-->Settings-->Document class and double checked it is set to "IEEE Transactions" and Custom: journal.

1

ieeetran.cls has

\def\figurename{Fig.}
\def\tablename{TABLE}
\@IEEEcompsocconfonly{\def\figurename{Figure}}

so should be using Fig. except in the IEEE comp soc conf setting. You can always add

\renewcommand\figurename{Fig.}

to set it back.

  • I have this in my lyx preample, and it shows Figure 1. still % for subfigures/subtables \usepackage[caption=false,font=footnotesize]{subfig} %\renewcommand\figurename{Fig.} I also tried commenting out that first line, but that doesn't work either. – Veridian Nov 14 '14 at 0:50
1

I had to add the following to the preample and it worked correctly:

\addto\captionsenglish{\renewcommand{\figurename}{Fig.}}

I referenced this answer: Change caption name of figures

I tried following David Carlisle's suggestions of adding \renewcommand\figurename{Fig.} but that actually didn't work regardless of where I place it in the preamble. It also caused Lyx to show error messages when I tried compiling to a PDF.

1

Another solution via @Werner:

Make sure that you also remove the use of babel in your preamble. That is, under Document > Settings... > Language, select None in terms of the language package to use:

See this answer for more information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.