3

I'm new to LaTeX and am trying to switch from hardcoded \bibitem references to natbib. I have all my references in Mendeley and exported them to a .bib file. My code is generating no errors (yay!) but is also failing to make any references appear. All of the documentation I've read suggests that one only needs \bibliographystyle and \bibliography to make them appear...any thoughts? I looked at the .bib file and it appears to match everything expected (I also tried to construct a MWE with only one reference but it still failed to appear). All I get is my "test" text.

Thanks for any insights!

\documentclass[english]{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{graphicx}
\PassOptionsToPackage{normalem}{ulem}
\usepackage{ulem}
\usepackage{babel}
\usepackage{ulem, setspace, fullpage}
\setlength\parindent{24pt}
\usepackage[round]{natbib} 

\begin{document}
test
\newpage
\bibliography{Zotero-Coresidence}
\bibliographystyle{plainnat}

\end{document}
  • Welcome to TeX.SX! – user31729 Nov 14 '14 at 17:17
  • You didn't mention whether you ran BibTeX as well as LaTeX. Please advise. Please also report if there are error messages in the \jobname.blg file. – Mico Nov 14 '14 at 17:57
  • I'm not sure I understand this comment. I ran pdfLaTeX and then BibTeX and then pdfLaTeX again, but there are no .blg files in the folder--just .aux, .run, and .bbl (in addition to the Tex file). – Melanie Nov 14 '14 at 18:25
  • Are you saying that there's a new \jobname.bbl (where \jobname is the name of your main tex file) in the folder, but no file named \jobname.blg? – Mico Nov 14 '14 at 18:34
  • 3
    There are no citations in your example, so it's not surprising you see no bibliography. If you want to add a bibliography without citations, use \nocite (selectively) or \nocite{*} (add everything). – Joseph Wright Nov 14 '14 at 18:36
1

Remove the quotes from you bibliography path. Also you should be aware that it us easier to place your bibliography in the same directory and then just write the name ' biblio' (without the .bib extension). You can also make relative references. Say your bibliography is in another subfolder in your project. Then you can write 'bib/biblio'

  • That true. I will update my answer. – Rud Faden Nov 14 '14 at 18:02
  • I removed the quotes and put it in the same folder so that I can reference it directly. I ran BibTeX after pdfLaTeX and then ran pdfLaTeX again. Now I'm getting a page that actually says "References" on it, but doesn't have any references displayed. – Melanie Nov 14 '14 at 18:24
  • Run pdflatex twice, then bibtex and then pdflatex – Rud Faden Nov 14 '14 at 19:37
  • Or maybe it is to times after bibtex.. Usually most modern latex editor's will use latexmk script that figures the whole thing out. – Rud Faden Nov 14 '14 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.