[Update] This is solved thanks to Adam Liter's contribution in chat. This is summarised to a community answer below.

I cannot understand why the references do not get compiled. I am running Yosemite 10.10 and newest MacTeX. They got compiled in another document a few days ago. We are having a discussion about this bug in the chat -- welcome to join us!

Why are the references not getting compiled?

enter image description here




\section{Problem Statament \cite{problemStatement}}


    Date-Added = {2014-11-17 15:45:23 +0000},
    Date-Modified = {2014-11-17 15:46:00 +0000},
    Lastchecked = {17th November 2014},
    Url = {http://www.ipt.ntnu.no/~kleppe/TPG4150/2014.pdf}}
  • Given the lack of the MWE in what you provided, 3 questions. First, why are you hard-coding the numbered items in the References block? Second, what type of citation were you expecting in the \cite{groupWork} command? Third, any reason why the groupWork bibliography entry has no author or title? If the default citation style expects either, there could be a problem. Nov 17, 2014 at 1:21
  • Why \addbibliographysource? (I've never seen this before.) Sorry, but I am not downloading a random DropBox file just to answer a question. If you don't have time to create an MWe, you don't have time to ask the question. But you could at least post it as a text file somewhere it can be viewed.
    – cfr
    Nov 17, 2014 at 1:24
  • @cfr what would you use instead?
    – hhh
    Nov 17, 2014 at 1:26
  • 2
    The bold groupWork is a cite command which hasn't been resolved yet - either because you didn't run biber, or because biber gave an error or because the bib entry is not in the bib-file. Nov 17, 2014 at 10:40
  • 4
    I'm voting to close this question as off-topic because it has been solved by updating the TeX packages.
    – LaRiFaRi
    Jul 19, 2015 at 7:54

1 Answer 1


Update3: keep the MacTeX automatically updated

sudo su
tlmgr update --self --all

Update 2: removing the cache of biber solved the reoccurring problem

The biber problem reoccurred and egreg directed to the solution Biblatex/biber fails with a strange error about missing recode_data.xml file so

rm -rf `biber --cache`

Update 1: updating MacTex solved the problem

This was an OSX related thing: I had biber 1.8 and after updating the whole TeX Live with "Tex Live Utility" things started to work. It was not enough to update to the newest MacTeX! You have to also update things with the Graphical tool in OSX!

enter image description here

I thank Adam Liter for finding the solution in the chat:

I'm on a Mac right now, and I get the same error you see in System Preferences. However, I haven't had any problems updating my TeX distro with TeX Live Utility. If you just search TeX Live Utility in Spotlight, you should see it come up. After you open it, it will allow you to update all of your packages.

  • 3
    rm -rf `biber --cache` worked for me! Dec 27, 2015 at 0:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.