1

I am writing lecture notes in LyX 2.1 on Windows and I have recently enabled hyperref in document settings and since then I get strange crossed L marks before every formula I put, e.g.:

enter image description here

Anybody knows how can I solve it? Maybe I'm missing a crucial package?

EDIT: The mwe is available at http://textuploader.com/onny

and on TeX format:

\documentclass[english]{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{babel}
\usepackage{amsmath}
\usepackage[unicode=true,pdfusetitle,
 bookmarks=true,bookmarksnumbered=false,bookmarksopen=false,
 breaklinks=false,pdfborder={0 0 1},backref=false,colorlinks=false]
 {hyperref}
\begin{document}
\global\long\def\difrac#1#2{\frac{\partial#1}{\partial#2}}
\global\long\def\l{\ell}
\subsection{Hyperbolic equations without humuganous conditions}
Take a look at the equations of the form:
\begin{eqnarray}
u_{tt} & = & a^{2}u_{xx}+g\left(x,t\right),\quad0<x<\l,t>0\\
u\left(x,t\right)\bigg|_{t=0} & = & f\left(x\right)\\
\difrac{u\left(x,t\right)}t\bigg|_{t=0} & = & F\left(x\right)\nonumber \\
u\left(0,t\right) & = & \mu_{1}\left(t\right)\\
u\left(\ell,t\right) & = & \mu_{2}\left(t\right)\nonumber 
\end{eqnarray}
Use the method from $\left(4.28\right)$on $\nu\left(x,t\right)$
\[
v\left(x,t\right)=A\left(t\right)x+B\left(t\right)
\]
\[
\begin{cases}
v\left(0,t\right)=B\left(t\right)=\mu_{1}\left(t\right)\\
v\left(\l,t\right)=\l A\left(t\right)+B\left(t\right)=\mu_{2}\left(t\right) & \Rightarrow A\left(t\right)=\frac{\mu_{2}\left(t\right)B\left(t\right)}{\l}
\end{cases}
\]
\begin{equation}
v\left(x,t\right)=\frac{x}{\l}\left[\mu_{2}\left(t\right)-\mu_{1}\left(t\right)\right]+\mu_{1}\left(t\right)
\end{equation}
\end{document}
  • 1
    Please provide a MWE. You can create this in LyX, save and then open the document using a text editor. Paste that content as your MWE. Please make sure compression is not enabled when saving. – penguinpreferred Nov 19 '14 at 3:44
  • Yes please provide a .lyx MWE: wiki.lyx.org/FAQ/MinimalExample . Also, if the issue you see is only there when using Hebrew, this is important to know. – scottkosty Nov 19 '14 at 3:50
  • I uploaded a MWE in English. Hebrew seems to be (allegedly) irrelevant. – Danis Fischer Nov 19 '14 at 3:51
  • @DanisFischer the Hebrew is relevant. I can reproduce the problem you see. If I then select all and then go to Edit > Language and click on English (even if there is already a check), the problem goes away for me. – scottkosty Nov 19 '14 at 4:01
  • 1
    What happens if you get rid of the macro \l and simply write \ell everywhere instead of \l? – Mico Nov 19 '14 at 6:44
2

hyperref together with Hebrew and pdftex has never worked properly. However, recently I had success with modern versions of XeTeX in which hyperref and Hebrew do work together.

You can follow this tutorial to set LyX to typeset Hebrew using XeTeX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.