6

This question already has an answer here:

I have a Beamer presentation with note pages, in which everything renders just fine with pdflatex.

However, when the file is compiled using xelatex (I need to use fontspec), texts in frames after a note page are not visible -- they are rendered in white colour. This problem is reproducible when using Beamer v3.33.

%% Compile with xelatex
\documentclass[handout]{beamer}

\mode<handout>
{
\setbeameroption{show notes}
\RequirePackage{pgfpages}
\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]
}

\begin{document}
\begin{frame}
A test, A test!
\note{ }
\end{frame}    

\begin{frame}
This text does not appear!
\note{ }
\end{frame}
\end{document}

While this problem can be solved by compiling with lualatex, I'm wondering if there's any thing one can do to make it work for xelatex?

marked as duplicate by user36296, Zarko, darthbith, Jesse, egreg xetex Apr 27 '16 at 17:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    This seems to be related to the problem described in tex.stackexchange.com/questions/188174/… and discussed in tug.org/mailman/htdig/xetex/2014-June/025326.html – Thomas F. Sturm Nov 20 '14 at 7:51
  • Try adding the fragile option as such \begin{frame}[fragile] ... \end{frame}. – Jesse Nov 20 '14 at 9:47
  • @ThomasF.Sturm Thanks for the links. Looks like it's something to do with the drivers. – LianTze Lim Nov 20 '14 at 10:15
  • @Jesse Nope, doesn't work. – LianTze Lim Nov 20 '14 at 10:17
  • Thanks, I verified your invisible page on my side, added fragile then the invisible page becomes visible. But later on, I disabled the fragile option, the visible page is still there. Sorry, my bad. Should have tested more before commenting. – Jesse Nov 20 '14 at 10:41
2

As a workaround, one can reset to normal colour at the begin of every frame:

%% Compile with xelatex
\documentclass[handout]{beamer}

\mode<handout>
{
    \setbeameroption{show notes}
    \RequirePackage{pgfpages}
    \pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]
}

\makeatletter 
\def\beamer@framenotesbegin{% at beginning of slide
    \usebeamercolor[fg]{normal text}
    \gdef\beamer@noteitems{}% 
    \gdef\beamer@notes{}% 
}
\makeatother

\begin{document}
    \begin{frame}
        A test, A test!
        \note{ }
    \end{frame}    

    \begin{frame}
        This text does not appear!
        \note{ }
    \end{frame}
\end{document}

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.