6

I've looked everywhere for an answer to this question, but none could answer this specific one:

I have MinionMath font (from typoma.com, MinionMath-Regular.otf) and I want to use unicode f3a0f (under "Supplementary Private Use Area-A") but I have no idea how to get it using LuaLaTeX. I can't just use \symbol{"f3a0f} as that doesn't work... Not sure what to do.

This is a pdf file that has all the symbols. I want to use symbol f3a0f (top right of page 19) specifically (and yes, I'm aware it looks similar to |, but I want to use this particular one). I did take a look at this question but for some reason there just is no temp-minionmath file at all in the .log file. I have also looked at a number of other questions but they don't seem to work :(

I need to use LuaLaTeX only, I know how to do this in XeTeX, but I absolutely 100% need it in LuaLaTeX unfortunately. Any help would be appreciated.

Edit: Here is some "compilable" code (This is a pretty basic question so really I want to be able to use this symbol with this code as a bare minimum...)

\documentclass{article}
\usepackage{unicode-math}
\setmathfont{MinionMath-Regular.otf}
\begin{document}
 \[󶆽\]
\end{document}

EDIT 2: It now appears I have located the MinionMath-Regular.lua file after all thanks to @UlrikeFischer 's comment, and when I find the corresponding symbol number for F3A0F (\symbol{983854}) and type that into the file / compile with LuaLaTeX, that indeed works. Now I guess the question is, how come a simpler method such as \char{"F3A0F} or ^^^^^f3a0f doesn't work with LuaLaTeX, when it should? I'd rather not have to search through the .lua file for a corresponding symbol number each time.

  • 3
    Just to start, you could say how to do it in XeTeX which might help others in the future. And, as always, an small piece of compilable code is welcome (or not compilable, in this case). That way you remove the burden from other users to write the basic document to start with your problem. Welcome to TeX.SE by the way! – Manuel Nov 21 '14 at 1:33
  • Hi @Manuel , this question shows how to generate a table of glyphs with XeTeX. Also, I'm not sure how useful the code would be since the question is very very basic, but sure I'll put it in. – airatin Nov 21 '14 at 1:39
  • 2
    Yes, there is no longer a temp-...lua mentioned in the log-file - luaotfload has dropped this prefix. But there should be quite a lot of luaotfload messages and also the name and the path of the cache file of the font. In this folder you should find .lua and .luc (packed) files. Use the .lua file to find your symbol. – Ulrike Fischer Nov 21 '14 at 7:57
  • @UlrikeFischer when I search the log file for anything that has ".lua" in it, I don't find anything that looks like "MinionMath.lua" or anything of the sort. I find plenty of .lua files but none that have MinionMath or similar for some reason... – airatin Nov 21 '14 at 11:36
  • 1
    @UlrikeFischer wow... I just looked at the log file and you're right, there is a MinionMath-Regular.luc file that shows, and if I go to that file location I can find the corresponding .lua file!! So I copied that unicode's corresponding number (\symbol{983854}) and it works when written into LuaLaTeX! I can't believe I didn't try this before, thank you! Now I just wish there was some easier way for me to do this without having to look for the symbol in this file... Ah well. – airatin Nov 21 '14 at 11:51
7

Well, Private Use Areas are part of Unicode, they just have no predefined meaning. So you can use them like any other character, e.g. by simply typing it (if you have an appropriate input method) or using the character code either as \char"F3A0F or ^^^^^f3a0f.

If I run your example here, I get a PDF with the symbol both with LuaTeX and XeTeX.

  • Hi @Khaled-Hosny, it's interesting you say this because honestly when I run LuaLaTeX with that character code, a blank page appears. In the log file, it actually even says "Missing character: There is no 󳨏 (U+F3A0F) in font "[MinionMath-Regular.otf]"! But XeTeX works fine for some reason with this, which is frustrating because I need LuaLaTeX :( Also, even if I copy this symbol from, say, the XeTeX output pdf or copy-paste 󳨏 directly into the file, the pdf will still appear blank in LuaLaTeX. – airatin Nov 21 '14 at 11:35
  • actually it turns out I could locate MinionMath-Regular.lua file and find the unicode's corresponding number (\symbol{983854}); using that, the symbol appears in LuaLaTeX. But I'm curious as to why the \char or ^^^^^ method doesn't work for LuaLaTeX when it should, would be a lot easier to use that method instead of searching the .lua file each time... Was wondering if you had any idea how come it doesn't work? If not, I'll have to use this, but thank you anyway! – airatin Nov 21 '14 at 11:55
  • Might be that the lua files are staled old version, or that you have two different versions of the font. Here all works just fine out of box. – Khaled Hosny Nov 21 '14 at 12:17
  • would you happen to know how would I get a new .lua file (I thought they're just generated when you compile in LuaLaTeX)? Also, I know I only have 1 version of the font (it was sent to me via email and I manually installed it). Thanks again! – airatin Nov 21 '14 at 12:23
  • Deleting both the .lua and .luc files should trigger re-generating them in the next LuaTeX run. – Khaled Hosny Nov 21 '14 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.