3

i have 2 issues with my document

A. First of all i never thought it would be so difficult to have 0 indent in 1st paragraph following chapter, section an subsection headings.
I've read that it's 0 by default with memoir class, but i end up with an indent in every paragraph. I believe one of the packages i'm using creates the problem, but i can't figure out which one.

B. Secondly, i want to be able to change the baselineskip (if that's the correct value i need to modify) inside the chapter title.
As you can see i have my chapter title stretched in 3 lines which i want to bring closer to one another (squeeze them vertically) and if possible, do the same for the sections, subsections, etc.

This is my preamble

\documentclass[9pt,draft,twoside,openright,showtrims]{memoir}  
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{mathspec,xunicode,xltxtra}  
\usepackage{polyglossia}  

\usepackage{tabularx}
\usepackage{footnote}
\usepackage{setspace} 

\renewcommand{\baselinestretch}{1.25}

\setmainfont[
 Ligatures=TeX,
 BoldFont={FedraSansPro Bold.otf},
 ItalicFont={FedraSansPro BookItalic.otf},
 BoldItalicFont={FedraSansPro BoldItalic.otf}
]{FedraSansPro Book.otf}

\newfontfamily\greekfont[Script=Greek, Mapping=tex-text, BoldFont = FedraSansPro Bold.otf, ItalicFont = FedraSansPro BookItalic.otf]{FedraSansPro Book.otf} 
\newfontfamily\englishfont[Mapping=tex-text, BoldFont = FedraSansPro Bold.otf, ItalicFont = FedraSansPro BookItalic.otf]{FedraSansPro Book.otf}

\setmainlanguage[variant=monotonic]{greek} 
\PolyglossiaSetup{greek}{indentfirst=false}
\setotherlanguage{english}
\newcommand{\en}{\selectlanguage{english}}

\makeatletter %
\makechapterstyle{sofia}{
  \setlength{\beforechapskip}{-48pt}
  \setlength{\midchapskip}{0.5\baselineskip}
  \setlength{\afterchapskip}{7\baselineskip}
  \renewcommand{\chapterheadstart}{\vspace*{\beforechapskip}}
  \renewcommand{\chapnamefont}{\raggedright\bfseries\huge}
  \renewcommand{\printchaptername}{\chapnamefont \@chapapp}
  \renewcommand{\chapternamenum}{\space}
  \renewcommand{\chapnumfont}{\normalfont\huge}
  \renewcommand{\printchapternum}{\chapnumfont \thechapter}
  \renewcommand{\afterchapternum}{\par\nobreak\vskip \midchapskip}
  \renewcommand{\printchapternonum}{\vspace*{\midchapskip}\vspace*{5mm}}
  \renewcommand{\chaptitlefont}{\raggedright\bfseries\HUGE}
  \renewcommand{\printchaptertitle}[1]{\chaptitlefont ##1}
  \renewcommand{\afterchaptertitle}{\par\nobreak\vskip \afterchapskip}
}
\makeatother

\chapterstyle{sofia}

%My section styles
\setsecheadstyle{\normalfont\huge\bfseries}
\setsubsecheadstyle{\normalfont\large\bfseries}
\setparaheadstyle{\normalfont\normalsize\bfseries}
\setparaindent{0pt}\setafterparaskip{0pt}
\setsubsubsecindent{2.5\parindent}

\checkandfixthelayout
\fixpdflayout
\trimFrame

\begin{document}  
\chapter{Αποτελεσματικότητα \newline του Ανταγωνιστικού \newline Υποδείγματος}  
\section{Αποτελεσματικότητα και Κοινωνική \newline Ευημερία}  
\subsection{Κριτήρια Ευημερίας}  
\subsubsection*{Το Κριτήριο του \textit{\en{Pareto}}}  
Σύμφωνα με το κριτήριο του {\en \textit{Pareto}} η μετακίνηση από το αρχικό σημείο        ισορροπίας θα είναι επιθυμητή, εάν η χρησιμότητα τουλάχιστον του ενός καταναλωτή αυξηθεί χωρίς να μειωθεί αντίστοιχα η χρησιμότητα του άλλου. Δηλαδή, εάν ισχύει        \begin{equation}
 u_{a}^{0}<u_{a}^{1}\ \  \text{και} \ \  u_{b}^{0}\leq u_{b}^{1}  \ \ \ \ \  \text{ή} \    \ \ \ \ u_{b}^{0}<u_{b}^{1}\  \ \text{και} \ \ u_{a}^{0}\leq u_{a}^{1} \notag
\end{equation}
\end{document}

And this is my result with the arrows pointing what i'm trying to achieve (but with a different font)

enter image description here

  • You use polyglossia, but set no language, at least in the example. Please, make it consistent. – egreg Nov 21 '14 at 11:38
  • @egreg Sorry for that, i edited my preamble – S.M Nov 21 '14 at 11:44
  • Does anyone know of a greek font available in TL14? I do not use xelatex that much. It does seem to be related to greek and polyglossia, since if I choose english as the main language (after replaceing the greek text with ascii babble), than the first paragraphs after a section is not indented. But under greek they are. Perhaps this is intentional? – daleif Nov 21 '14 at 11:56
  • @daleif I don't see why this would be intentional for greek text – S.M Nov 21 '14 at 12:14
  • Me neither (but it could be a design choice for greek texts, in the same manner as there are special design choices in french typography). There are no specific polyglossia related code in memoir so it seems to some from there. – daleif Nov 21 '14 at 12:31
3

You shouldn't call setspace with memoir (but it's innocuous, as the class doesn't load it to begin with).

If you really want such a big interline space, then it should be the same in titles, in my opinion, but it's possible to do how you'd like.

\documentclass[9pt,draft,twoside,openright,showtrims]{memoir}  
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{mathspec}
\usepackage{polyglossia}  

\usepackage{tabularx}
\usepackage{footnote}

\setmainlanguage[variant=monotonic]{greek} % variant can be polytonic, monotonic, or ancient 
\PolyglossiaSetup{greek}{indentfirst=false}
\setmainfont{GFS Artemisia}

\setotherlanguage{english}


\newrobustcmd{\en}[1]{\foreignlanguage{english}{#1}}

\setSpacing{1.25}

\makeatletter
\makechapterstyle{sofia}{
  \setlength{\beforechapskip}{-48pt}
  \setlength{\midchapskip}{0.5\baselineskip}
  \setlength{\afterchapskip}{7\baselineskip}
  \renewcommand{\chapterheadstart}{\vspace*{\beforechapskip}}
  \renewcommand{\chapnamefont}{\raggedright\bfseries\huge\SingleSpacing}
  \renewcommand{\printchaptername}{\chapnamefont \@chapapp}
  \renewcommand{\chapternamenum}{\space}
  \renewcommand{\chapnumfont}{\normalfont\huge}
  \renewcommand{\printchapternum}{\chapnumfont \thechapter}
  \renewcommand{\afterchapternum}{\par\nobreak\vskip \midchapskip}
  \renewcommand{\printchapternonum}{\vspace*{\midchapskip}\vspace*{5mm}}
  \renewcommand{\chaptitlefont}{\raggedright\bfseries\HUGE}
  \renewcommand{\printchaptertitle}[1]{\chaptitlefont ##1}
  \renewcommand{\afterchaptertitle}{\par\nobreak\vskip \afterchapskip}
}
\makeatother

\chapterstyle{sofia}

%My section styles
\setsecheadstyle{\normalfont\huge\bfseries\SingleSpacing}
\setsubsecheadstyle{\normalfont\large\bfseries\SingleSpacing}
\setparaheadstyle{\normalfont\normalsize\bfseries}
\setparaindent{0pt}\setafterparaskip{0pt}
\setsubsubsecindent{2.5\parindent}

\checkandfixthelayout
\fixpdflayout
\trimFrame

\begin{document}  

\chapter[Αποτελεσματικότητα]{Αποτελεσματικότητα \newline 
  του Ανταγωνιστικού \newline Υποδείγματος}

Σύμφωνα με το κριτήριο του \en{\textit{Pareto}} η μετακίνηση από το αρχικό σημείο 
ισορροπίας θα είναι επιθυμητή, εάν η χρησιμότητα τουλάχιστον 

Σύμφωνα με το κριτήριο του \en{\textit{Pareto}} η μετακίνηση από το αρχικό σημείο 
ισορροπίας θα είναι επιθυμητή, εάν η χρησιμότητα τουλάχιστον 

\section{Αποτελεσματικότητα και Κοινωνική \newline Ευημερία}

Σύμφωνα με το κριτήριο του \en{\textit{Pareto}} η μετακίνηση από το αρχικό σημείο 
ισορροπίας θα είναι επιθυμητή, εάν η χρησιμότητα τουλάχιστον 

\subsection{Κριτήρια Ευημερίας}

Σύμφωνα με το κριτήριο του \en{\textit{Pareto}} η μετακίνηση από το αρχικό σημείο 
ισορροπίας θα είναι επιθυμητή, εάν η χρησιμότητα τουλάχιστον 

\subsubsection*{Το Κριτήριο του \en{\textit{Pareto}}}

Σύμφωνα με το κριτήριο του \en{\textit{Pareto}} η μετακίνηση από το αρχικό σημείο 
ισορροπίας θα είναι επιθυμητή, εάν η χρησιμότητα τουλάχιστον του ενός καταναλωτή αυξηθεί 
χωρίς να μειωθεί αντίστοιχα η χρησιμότητα του άλλου. Δηλαδή, εάν ισχύει
\begin{equation*}
u_{a}^{0}<u_{a}^{1} \quad \text{και} \quad u_{b}^{0}\leq u_{b}^{1}
\qquad \text{ή} \qquad
u_{b}^{0}<u_{b}^{1} \quad \text{και} \quad u_{a}^{0}\leq u_{a}^{1}
\end{equation*}

\end{document}

Note that I used \setSpacing and not \renewcommand{\baselinestretch}; moreover I added \SingleSpacing for the titles.

Finally, defining \en to do \selectlanguage{english} is not really the best, see how I changed it.

For no indent on the first line after a title, it's a “secret trick”. ;-) Not really, it is explained in the manual of polyglossia.

enter image description here

  • 1
    Ahh, there it was. Why is that option for polyglossia not mentioned in the manual? – daleif Nov 21 '14 at 12:33
  • @egreg Thanx a lot for the answer although it doesn't work for me very well, should i post a big comment or an answer maybe? i am new here – S.M Nov 21 '14 at 13:19
  • @SofiaMouseti Can you briefly tell what the problems are? – egreg Nov 21 '14 at 13:38
  • @egreg I edited my origianl preamble so you can see the actual definitions of fonts. (i used artemisia before for simlpicity reasons) I declare them by name, so if i have to put \setmainfont{FedraSansPro Book.otf} it will force this font everywhere and the bfseries i declare further down, won't have an effect in chapter and section headings – S.M Nov 21 '14 at 13:57
  • @egreg The indentation works fine though – S.M Nov 21 '14 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.