2

I have seen some solutions on here to problems regarding removing red boxes from hyperlinks, but I have an issue with red boxes around references. Whenever I use the commands \eqref{} or \footnote{} the number in the PDF has a big red box around it. I have linked the issue to my classicthesis package. I like the formatting of this package, but I don't want to have red boxes around my references. What can I do? My document preamble is:

\documentclass[hidelinks,a4paper]{report}
\usepackage{mathtools}
\usepackage{setspace}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage{amsfonts}-\usepackage{amsthm}
\usepackage{classicthesis}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage[colorinlistoftodos]{todonotes}
6
  • 2
    Isn't tex.stackexchange.com/questions/823/… what you need?
    – egreg
    Nov 21, 2014 at 18:04
  • 1
    \PassOptionsToPackage{draft}{hyperref} before \documentclass will remove them quite for sure, but it will remove all functionality of hyperref. For other solutions, use answers in what @egreg linked.
    – yo'
    Nov 21, 2014 at 18:06
  • @egreg, I tried that but then it complained that the package conflicted with the command \begin{document}
    – Josh
    Nov 21, 2014 at 18:16
  • LaTeX Error: Option clash for package hyperref. See the LaTeX manual or LaTeX Companion for explanation. Type H <return> for immediate help. ... l.14 \title {Alternate Methods of Calculus with Absolute Value Functions}
    – Josh
    Nov 21, 2014 at 18:18
  • \hypersetup{hidelinks} should do. An example of your document preamble should be needed, add it to your question.
    – egreg
    Nov 21, 2014 at 18:19

2 Answers 2

3

I avoid the option clash for hyperref by loading:

\usepackage[svgnames]{xcolor}

The last package in my preamble is:

\usepackage[colorlinks=true, linkcolor=Maroon, urlcolor=Maroon]{hyperref}

Obviously, you should use your own preferred colours.

I struggled with this for quite a while when I was designing the template for a scholarly journal but after some digging around, settled on this. I don't have time just now to re-trace the steps I took in finding this out but I will do so if nothing comparable works for you.

3
  • Welcome to TeX.SX! You should definitely come back and elaborate on this answer
    – user31729
    Nov 21, 2014 at 22:05
  • @Christian Oh, and thanks for the warm welcome!
    – Ian Astley
    Nov 21, 2014 at 23:29
  • Just had a quick check. The (Boolean) option colorlinks is set to false by default. If set to true, it colours the links rather than putting them in a bounding box. The manual gives an indication of this (but it is not wholly clear). The manual will be at /usr/local/texlive/2014/texmf-dist/doc/latex/hyperref/manual.pdf; refer to section 3.5
    – Ian Astley
    Nov 22, 2014 at 19:02
0

the answer is here:

https://stackoverflow.com/questions/47923066/how-to-get-rid-of-the-red-box-around-hyperlink-in-pdf

it is

\usepackage[hidelinks]{hyperref}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.