1

I've downloaded an .otf font (specifically one called Dalelands Uncial) that I would like to use in a document. I've double-clicked on the file and selected install, so that it now sits in my ~/Library/Fonts folder on my Mac and Font Book claims the file is installed.

I thought that running LuaLaTeX on the following minimal example would now allow me to access the font, but it doesn't work.

\documentclass{article}
\usepackage{fontspec}
\setmainfont[
    Path = /Users/<myname>/Library/Fonts,
    Extension = .otf,
    Ligatures = TeX
]{Dalelands Uncial}
\begin{document}
Some sample text.
\end{document}

(This is my attempt to replicate what is suggested in the first answer to this question.)

I'm told that "DalelandsUncial" cannot be found. Is it the space in the name causing a problem?

  • 1
    Try Dalelands_Uncial – Yiannis Lazarides Nov 22 '14 at 17:11
  • 1
    It shouldn't be necessary to specify either the path or the extension if the font has been installed. But as indicated by Yiannis, the mistake must be in the {Dalelands Unical} part. – Sverre Nov 22 '14 at 17:16
  • Do you have an up-to-date Texlive 2014? If not a manual run of luaotfload-tool --update might be necessary – MaxNoe Nov 22 '14 at 17:51
  • Tried those: "Dalelands_Uncial" gives the same error. Also just ran luaotfload-tool --update and I still get the same error. – Martyn Quick Nov 22 '14 at 18:08
  • 2
    I have downloaded the font from dafont.com/it/dalelands.font and installed it in ~/Library/Fonts. Your document, after removing Path=... and Extension=... compiles without problems (LuaTeX triggers a run of luaotfload-tool the first time). – egreg Nov 22 '14 at 18:36
1

With further experimentation, I have now found an answer that works for TeXlive as installed on my machine. I have no idea why this one works for me, but the one that works for @egreg does not.

It turns out that all I needed to do was put the .otf files in a subdirectory of ~/Library/texlive/2014/texmf-var/fonts and they can then be found by LuaLaTeX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.