0

Suddenly my TexStudio installation keeps crashing 'due to SIGSEGV'. It happens as soon as I try and make a new document from a template, or on the second run and compile. Curiously, the first run and compile works, but the second hangs and eventually crashes 'due to SIGSEGV'.

I've tried the following:

  • Reinstall TexStudio 2.8.6
  • Uninstall and install TexStudio 2.8.4
  • Install TexMaker. TexMaker behaves in the same way.
  • Use another editor. TexShop works fine (I just don't like it and want TexStudio back!)
  • Restart computer
  • Reinstall full MacTex package

Any ideas?

Thanks

  • Somebody may know. In case they don't: which version of OS X? Did this behaviour follow any changes to the OS or environment? (Update? New software?) Does the same thing happen if you create a new user account, log in as that user and repeat those actions? Any useful information in the logs? (If not, you might get more information by starting the application from the command line.) Are other applications behaving normally? – cfr Nov 23 '14 at 2:01
  • The first thing I'd suspect is faulty memory. You can test that with the built-in diagnostics by restarting your Mac and holding down the D key as it restarts. Reference: Macworld: Do you have bad RAM? How to find it and how to fix it – Mike Renfro Nov 23 '14 at 2:01
  • @MikeRenfro Do you have any particular reason for that? I've seen a lot of segmentation faults and only rarely has bad RAM been the culprit. (Faulty software is more usual.) But that's why logs etc. are helpful. If the same components of software are always involved, it is less likely RAM which would cause more random failures. Testing doesn't hurt, though (just takes a while). Run the testing overnight is best. – cfr Nov 23 '14 at 2:09
  • Thanks guys. Mac OS is 10.10.2 which could be the culprit since I believe it was only installed yesterday. I've tried under another user and the same behaviour prevails. How do I get information through the command line? I know of "open -a TeXstudio" but this doesn't give any info. Other apps are fine. – jimbo Nov 23 '14 at 2:14
  • @cfr Sure, faulty software is first, but I'd eliminated that assuming that TeXstudio didn't have any such problems. But I've also seen segfaults happen with a few memory-intensive programs, and the root cause was still memory, since other programs weren't exercising memory as intensely. Regardless, since I'm not a TeXstudio user, I could certainly be unaware of any potential faults. My Mac may be on OS X 10.10.2 as well, but I won't know for certain until tomorrow. – Mike Renfro Nov 23 '14 at 2:55
1

It appears to be an issue with 10.10.2. I downgraded to 10.10 and all issues have been resolved!

  • If you have time (and like to help others), give the new version 2.9.2 a try as it has some OS X specific changes. If that doesn't help, I'm sure the team behind TeXstudio would appreciate if you file a bug – Jonas Nyrup Mar 23 '15 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.