0

I often use delimitmate plugin for autoclose. It works well in other file types except tex file.

In other file type such txt, when I typeset (, I will get () with the cursor between the parenthesis. However, in the tex file, nothing happens.

I have found someone having the same problem: https://github.com/Raimondi/delimitMate/issues/48. It turns out that delimitmate conflicts with vim-latex suit.

Is there any other plugin for autoclose working fine with vim-latex?

2

I had the same problem and asked this exact same question on here a couple of weeks ago. There were no answers and so I finally deleted my question.

Here is what I did as a workaround.

I also installed the vim plugin auto-close. This resolved my problem as far as automatically closing parenthesis, square braces etc were concerned. But then some of the ctrl-j functionality of vim-latex-suite gets disabled after that. But I can live with it. I actually find the place holder markers annoying. The only reason I use vim-latex-suite is to use ,ll and ,lv and forward searching and inverse searching capabilities.

This is perhaps not a complete solution to your problem, but it certainly worked for me. I also use the package snipmate in writing my .tex documents in latex. So there really is no need for all the fancy placeholder stuff that you get in vim-latex-suite. Hope that helps. Btw, my leader key is set to ,

I hope this helps.

  • Thanks very much. ctrl-j is useful for environment, but annoying sometimes. I have to do that trade-off. I think that giving up autoclose maybe OK. Besides, I use vim-latex-suite for another reason that I can use it on win7 with gvim. – Yulong Ao Nov 23 '14 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.