2

I'm writing a report for a class and I've run into a bit of formatting trouble. I'm trying to put page numbers on every page per report instructions and that includes the title page and abstract. I've tried putting \thispagestyle{plain} and \thispagestyle{empty} in a couple of places but what happens is the title page is numbered 1, then sometimes the abstract page is also numbered 1, and finally the beginning of the report is also numbered 1. How can I tell LaTeX not to restart the numbering? Below is my code up to now. I chose not to use the separate title page format because I wanted more customization that it would allow. I'm using Mac OS Mavericks.

Many thanks in advance for your assistance!

Code:

\documentclass[12pt, titlepage]{article}
\usepackage{times}
\usepackage{geometry}
\geometry{verbose,tmargin=1.00in,bmargin=1.00in,lmargin=1.00in,rmargin=1.00in}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{amsthm}
\usepackage{amsmath}
\usepackage{float}
\usepackage{hyperref}
\usepackage{setspace}
\DeclareGraphicsExtensions{.jpg, .eps, .png}

\begin{document}
\thispagestyle{plain}
\begin{center}
\vspace*{5cm}
\Huge{Title:}\\
\LARGE{Subtitle}\\
\vspace{2cm}
\Large{Me}\\
\vspace{1cm}
\large{Class Title}\\
\large{Class Number}\\
\large{School}\\
\large{Due Date is November 25, 2014}

\end{center}
\pagebreak

\begin{abstract}
\begin{doublespace}
Summing up results. 
\end{doublespace}
\end{abstract}

\section{Introduction}
\begin{doublespace}
TESTING THIS\\

\end{doublespace}
\end{document}
3
  • As far as I know, \doublespace is no environment and plain style does not affect the resetting of page numbers etc. times is deprecated. – user31729 Nov 23 '14 at 17:32
  • The easiest way is to remove the titlepage option from the documentclass specification – user31729 Nov 23 '14 at 17:51
  • See my updated answer please – user31729 Nov 23 '14 at 19:55
1

Since titlepage option is given to article class, the abstract environment uses a titlepage internally, thus the page numbers are reset. In order to correct, the resetting of page numbers has to be patched out as well as the call to \endtitlepage in the \endabstract command, being replaced by a \clearpage.

I did not address other issues with the original code

\documentclass[12pt,titlepage]{article}
\usepackage{mathptmx}%
\usepackage{geometry}
\geometry{tmargin=1.00in,bmargin=1.00in,lmargin=1.00in,rmargin=1.00in}
\usepackage{graphicx}
\usepackage{amssymb}
\usepackage{amsthm}
\usepackage{amsmath}
\usepackage{float}
\usepackage{setspace}
\usepackage{hyperref}
\DeclareGraphicsExtensions{.jpg, .eps, .png}

\usepackage{etoolbox}

\patchcmd{\titlepage}{\setcounter{page}\@ne}{}{\typeout{Success}}{\typeout{Failed}}% Drop the reset of page numbering
\patchcmd{\titlepage}{\thispagestyle{empty}}{}{}{}% Lazy patch ... kicking out the empty pagestyle and using the prevailing one

\patchcmd{\endabstract}{\endtitlepage}{\clearpage}{\typeout{Yes, patching worked}}{\typeout{Nothing worked}} % kick `\endtitlepage` out

\begin{document}
\thispagestyle{plain}
\begin{center}
\vspace*{5cm}
\Huge{Title:}\\
\LARGE{Subtitle}\\
\vspace{2cm}
\Large{Me}\\
\vspace{1cm}
\large{Class Title}\\
\large{Class Number}\\
\large{School}\\
\large{Due Date is November 25, 2014}

\end{center}
\pagebreak




\begin{abstract}
\begin{doublespace}
Summing up results. 
\end{doublespace}
\end{abstract}

\section{Introduction}
\begin{doublespace}
TESTING THIS\\

\end{doublespace}
\end{document}

enter image description here

3
  • This worked for avoiding the page number reset but I still can't get a page number to appear on my abstract page. For now I added "artificial" page numbers (centering and then entering the correct page number as a float) but if you have any other suggestions for putting a true page number in I'd love to see it. – PlanetaryPhD Nov 23 '14 at 19:43
  • Now it works perfectly! I'm really new to LaTeX so a "lazy fix" that works is enough for me! Thank you! – PlanetaryPhD Nov 23 '14 at 20:54
  • @AsteroidHunter: The fix is not lazy in itself, I just omitted the checks, that's lazy ;-) – user31729 Nov 23 '14 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.