I have been searching for a while now without any luck, so I hope you can help me. The problem is that when I insert a figure/longtabu on my page, the text below is running out of the page, like this image shows:

enter image description here

Do you know what the problem is here?

I have uploaded some sample code here: https://www.sharelatex.com/project/5460d3e57c82cd0747da476d

  • 1
    Please reduce your code to the minimum and include it to your post. Are you sure, it has something to do with some figure? I would say, the longtabu is preventing a page break here. Just guessing; I won't debug 97 lines for you.
    – LaRiFaRi
    Nov 25, 2014 at 11:56
  • My guess is the same as @LaRiFaRi, plus you are doing a lot of things wrong in that document. And additionally you are aware that the file does not even compile?
    – daleif
    Nov 25, 2014 at 12:27
  • Sorry for that. I must have been disturbed with something. I will fix it now.
    – 7heViking
    Nov 25, 2014 at 13:24
  • @LaRiFaRi I have reduced the code sample now and hope that you will have a second look at it.
    – 7heViking
    Nov 25, 2014 at 13:45
  • @daleif I have reduced the code sample now and hope that you will have a second look at it.
    – 7heViking
    Nov 25, 2014 at 13:47

2 Answers 2


Had the same issue over here, too. This worked for me


Apparently longtable had some issues on calculating the size of the page when a float is on the same page. I modified my longtable.sty file according to the instructions and now all is splendid, once again! :D

  • 1
    @DavidCarlisle: Is that patch still needed? Mar 14, 2015 at 20:08
  • 2
    @MartinSchröder for me (TexLive 2016 distro on Mac) - yes. I had to apply this patch (tried tlmgr update longtable before). Also bug status says it is still open since Arrival date: Sun Mar 09 21:41:00 +0100 2003. Seriously???
    – Tobi
    Sep 9, 2016 at 10:34
  • Please, tell me how to apply this patch. My latex installation does not have the /usr/share/texmf/tex/latex/tools folder Feb 5, 2019 at 22:00
  • On a Linux system, kpsewhich longtable.sty in the shell will tell you where it is located. Sep 9, 2019 at 8:23
  • @david-carlisle I still encounter this problem many years after being reported - tex.stackexchange.com/questions/507535/…
    – Viesturs
    Sep 9, 2019 at 13:03

I have no idea what is going on here. But I've reduced it to the following

It seems to be longtable related. I'll retag the question.



\begin{longtable}{ l }




\begin{longtable}{ l }

  • 2
    It works OK with v5 presumably the fix from tools/3512 in the latex bug database.... Nov 25, 2014 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .