1

OS: Windows 7.

TexLive: pdfTeX 3.1415926-2.5-1.40.14 (TeX Live 2013/W32TeX), kpathsea version 6.1.1

I was following rules https://www.tug.org/fonts/fontinstall.html

  1. I've updated my TexLive packages from ftp://tug.org/historic/systems/texlive/2013/tlnet-final from TeX Live Manager
  2. I've downloaded newtxtt.zip from http://www.ctan.org/tex-archive/fonts/newtxtt and unpacked to C:\texlive\texmf-local\fonts
  3. I've copied C:\texlive\texmf-local\fonts\newtxtt\tex to C:\texlive\texmf-local\tex\latex\local
  4. I've C:\texlive\texmf-local\fonts\newtxtt\tfm to C:\texlive\texmf-local\fonts
  5. Used mktexlsr
  6. Checked kpsewhich newtxtt.sty
  7. Used updmap-sys --enable Map=newtxtt.map

Running pdflatex for LaTeX file I get

(\end occurred when \ifx on line 1 was incomplete){c:/texlive/2013/texmf-dist/f
onts/enc/dvips/cm-super/cm-super-t1.enc}{c:/texlive/2013/texmf-dist/fonts/enc/d
vips/tex-gyre/q-ec.enc}
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+57/600 --dpi 657 newtxbtta

The command name is C:\texlive\2013\bin\win32\mktexpk

kpathsea: Running mktexmf newtxbtta.mf

The command name is C:\texlive\2013\bin\win32\mktexmf
name = newtxbtta, rootname = newtxbtta, pointsize =
mktexmf: empty or non-existent rootfile!
Cannot find newtxbtta.mf .
I try ps2pk --> gsftopk --> ttf2pk --> hbf2gf.
Font resources should be under a directory with the name "fonts".
Furthermore, there must be at least two directories under the directory "fonts".

Invalid path name.
Cannot get destination directory name.
kpathsea: Appending font creation commands to missfont.log.

!pdfTeX error: pdflatex.exe (file newtxbtta): Font newtxbtta at 657 not found
 ==> Fatal error occurred, no output PDF file produced!

I tried copying newtxtt subdirectories directly to fonts directory (in texmf-local). Same error.

Solution (from Bernard and cfr)

  1. Removing all newtxtt files from texmf-local
  2. updmap-sys --disable newtxtt.map
  3. Downloading newtxtt.tds.zip from ftp://ftp.dante.de/tex-archive/install/fonts/
  4. Unpacking to texmf-local (joins subdirs doc, fonts, tex)
  5. mktexlsr
  6. updmap-sys --enable Map=newtxtt.map

PdfLaTeX works.

  • You can download the tds-compliant newtxtt.tds.zip and unzip it at the root of texmf-local from here. – Bernard Nov 25 '14 at 17:55
  • @Bernard I've downloaded and unpacked. Very similar error. – mwloda Nov 25 '14 at 18:27
  • The package newtxtt is part of TeX Live. Is the issue that it is not in TL 2013 (or not the current version, anyway)? You should consider updating to TL 2014. However, if you don't wish to, I would try disabling the map file, removing all remnants of your manual copying into the tree, unzipping the tds as Bernard suggested, updating the name database, and then enabling the map. [In your original description, you don't say what you did with all the other files from the package, by the way!] – cfr Nov 25 '14 at 19:06
  • @cfr: Probably it wasn't part of TeXLive 2013, since version 1.01 dates back to June 1st, 2014. – Bernard Nov 25 '14 at 19:18
  • @cfr What do you exactly mean by disabling the map file? – mwloda Nov 25 '14 at 19:19
1

It would probably be best to think about updating to the latest version of TeX Live. However, if you are not currently able to upgrade, you can follow these steps to install the fonts:

  1. Disable the map file:

    updmap-sys --disable newtxtt.map

  2. Remove all traces of the packages left over from earlier manual installation attempts.

  3. Download the TDS archive as suggested by Bernard.
  4. Place the archive in the root of TEXMFLOCAL. If you are not sure where this is, get the value using

    kpsewhich --var=TEXMFLOCAL

  5. Unzip the archive.

  6. Update the file name database:

    mktexlsr $(kpsewhich --var=TEXMFLOCAL)

  7. Enable the map file:

    updmap-sys --enable Map=newtxtt.map

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.