I am using the following template for writing a document in Latex but i am getting an error Package Keyval Error: allcolors undefined..


% Load some packages 
%\usepackage[english]{babel}  % Use this if you are writing in English.
\usepackage[ngerman]{babel} % Use this if you are writing in German.

% Some settings
% \titlespacing{ command }{ left }{ before-sep }{ after-sep }[ right-sep ]

% Pdf annotation (Metadata for pdf document)
\hypersetup{pdftitle={Title for pdf Metadata}}
\hypersetup{pdfauthor={Forename Surename}}

University XYZ\hfill \today\\ % Date can also be set by hand (replace \today)
Faculty of Electrical Engg

% = Title ====================================
Template of Writing a Document in latex
% ============================================
--- Arbeitsplan zur Masterarbeit --- % Or Master's/Bachelor's Thesis Work Plan
% = Student ==================================
Bearbeiter: ABC\\ % Student
Course: Undergrad Program
% ============================================

% Load content from the file content.tex

% References as defined in the BibTeX file references.bib

  • No problem here when I comment out \input{content} and \bibliography{references} (since we don't have those). – Werner Nov 25 '14 at 20:04
  • @Werner: May be i am getting the error because i do not have the required package installed in my machine. The template is actually a working template but its giving me error in my machine. I am new to Latex so, i don't know how can i resolve the matter (i have already searched over internet.) – skm Nov 25 '14 at 20:05
  • See How do I update my TeX distribution? – Werner Nov 25 '14 at 20:12
  • @Werner: Sorry, as i mentioned that i am new to this thing so, only thing i could understand is that i should update my package manager and packages but when i am trying to run tlmgr update --list through the terminal (root user) then, it says that the command not found. – skm Nov 25 '14 at 20:19
  • Are you running TeX Live? What OS are you using? – Werner Nov 25 '14 at 20:20

Option allcolors was added to hyperref in version 2011-02-05 v6.82a. Therefore you need to update hyperref.

TeX distributions from Linux distributions are often very old and programs like tlmgr are disabled to avoid interference with the Linux packaging system.

But a recent TeXLive can be installed in parallel, e.g. see

How to install “vanilla” TeXLive on Debian or Ubuntu?How to install “vanilla” TeXLive on Debian or Ubuntu?

Enrico Gregorio: Installing TeX Live 2010 on Ubuntu

  • thanks for your answer. The same kind of suggestion is given in the above comments but the problem is that i am not able to update it through terminal. Terminal says No command 'tlmgr'. – skm Nov 25 '14 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.