2

I upgraded to Texlive 2014 on Unbutu 14.04 and trying to install non-freetonts with getnonfreefonts-sys. This command throws the following error:

 ERROR: The install directory '/usr/local/texlive/texmf-local' is not writable.

Then I tried the following command:

  wget http://tug.org/fonts/getnonfreefonts/install-getnonfreefonts
  sudo texlua install-getnonfreefonts
  getnonfreefonts -a

Then I used getnonfreefonts-l to check the installed fonts and this command shows Webomints font in this list.

Then I'm getting the this error

!pdfTeX error: pdflatex (file WebOMintsGD): Font WebOMintsGD not found

(Might be in different directory, looked this link for the same problem where fonts were in different directory). I'm not very expert and struggling with it. Any help will be highly appreciated. Thanks

  • 1
    sudo getnonfreefonts-sys -a? and delete ~/.texlive2014? – cfr Nov 27 '14 at 3:28
  • Thanks @cfr for your interest in my problem. Could you explain how to delete ~/.texlive2014? Is this will delete texlive2014? – MYaseen208 Nov 27 '14 at 3:47
  • No. It is a directory for generated files in your home directory. If it doesn't exist, don't worry about it. But if you have problems even when things are correctly installed, you may have stale files there and deleting the directory will force regeneration. – cfr Nov 27 '14 at 3:56
  • rm -rfv ~/.texlive2014 = delete + options 'recursive', 'force', and 'verbose' = forcibly delete without prompting the target and any subfiles while telling you about each thing it deletes. It is an easy command to misuse, so be careful with it. (cfr's suggestion is safe, however.) – jon Nov 27 '14 at 5:45
  • @MYaseen208 Beware of commands, if you don't understand them. Jons suggestion might be dangerous: If you add a space at the »right« place, it will delete your whole /home folder, without asking, and not just the folder ~/.texlive2014 . – Keks Dose Nov 27 '14 at 8:43
3

There is no need for installing texlive as root. It makes sense to set the owner of the texlive to the user:

sudo chown -R <username>.users /usr/local/texlive

Then you can run all <command>-sys as a default user.

  • Thanks @Herbert for your answer. I followed your instructions but still getting the error: !pdfTeX error: pdflatex (file WebOMintsGD): Font WebOMintsGD not found. The output of getnonfreefonts-sys shows Directories: temporary: '/tmp/getfont-<PID>' install: '/usr/local/texlive/texmf-local' and the output of getnonfreefonts shows Directories: temporary: '/tmp/getfont-<PID>' install: '/home/yaseen/texmf'. – MYaseen208 Nov 27 '14 at 15:19
  • Even better is to use a dedicated non-privileged user to manage the install. – cfr Nov 27 '14 at 15:45
  • @cfr: No, it is much more easier to run it as a user if it is a single user system. Then you'll never will have problems when mixing the default commands with the -sys extensions ... – user2478 Nov 27 '14 at 17:39
  • @MYaseen208: difficult to say what happens on your system. I just tried the three commands (without szdo) to download the foints and it worked. They were installed in /home/<user>/texmf/ – user2478 Nov 27 '14 at 18:43
  • @Herbert I agree that it is easier. But it is better to use an account other than your main user account. Convenience isn't everything ;). (It is still better to follow your advice than to use the root account, though.) – cfr Nov 27 '14 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.