I am writing documents with British and American spelling, and I have noticed that some 'common' words are not hyphenated. Examples include 'quar-ter-ly', 'pro-pen-si-ty', 'eu-ro-pean'. This can result in too much interword space (in my opinion), and I have to identify these instances manually.

I want to make sure that I am using everything correctly. For British spelling I use something like:



I know hyph-utf8 and load \input{ushyphex} for AE documents.

I have the following questions:

  • For BE, is loadhyph-en-gb loaded automatically when babel is loaded with british spelling?

  • Is there anything else I can do to ensure that some 'common' words are hyphenated.

  • If not, is there a way to identify where the typesetting could be improved so that I can create a hyphenation pattern myself?

Some related questions: LaTeX Hyphenation, Why does \usepackage[british]{babel} hyphenate the word "alternate" incorrectly?, How to add global hyphenation rules?, Where can I find a list of English hyphenation exceptions?

closed as unclear what you're asking by egreg, Joseph Wright Sep 5 '15 at 21:29

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Two of the three example words you've given -- quarterly and european -- are hyphenated correctly by LaTeX either out-of-box or with babel loaded with either the english (for US-English) or the british (for UK-english) option set, i.e., as quar-terly and eu-ro-pean. For English-language documents, the typographic convention is to set \righthyphenmin to 3; thus, inserting a hyphenation point before ly and an would not be considered standard typographic practice. This is, of course, quite different from, say, German language typographic practice. – Mico Nov 29 '14 at 13:27
  • @Mico Then I don't understand what's going on. "European" and "Quarterly" do not break (in my bibliography). Only after I specify the pattern myself they break correctly at "Euro-pean" and "Quar-terly". – Jörg Nov 29 '14 at 13:32
  • In your example, it looks like it's the global option UKenglish (which gets passed on to babel) that's causing the words quarterly, propensity, and european not to get hyphenated at all. Replace UKenglish with english and the problem disappears. – Mico Nov 29 '14 at 13:46
  • @Mico Well, but that is my question: I need to distinguish between AE and BE. If I use english US patterns are used. How can I fix this for BE? loadhyph-en-gb is supposed to break 90% of all words correctly. Is this loaded automatically with babel? – Jörg Nov 29 '14 at 13:52
  • There are also many words in BE that are not broken correctly: invest-igate, beha-vioural. So my question: are the patterns in loadhyph-en-gb wrong or simply not loaded? – Jörg Nov 29 '14 at 14:29