4

When I use the \citet command, it makes a the & sign between the names. It is not supposed to do that, it is supposed to spell out 'and', which is the correct style for in-text citation. However, I have a further problem, which is that I write in Danish, and I need it to spell out 'og' between the names instead of and. I have been trying to find a danish.apc file, or to create one myself from the swedish.apc file. So far, I have been unsuccessful in both. I tried the solution suggested on a similar issue, where someone was writing in catalan: Change citation conjunction from "and" to "i"

The solution there suggested here, however, does not yield an acceptable result because the commands do not do what is written that they do. The \renewcommand{\BBAA}{&} is supposed to change only the text in the references and between parantheses, that is, using the \citep command. But it also changes it within the text when using the \citetcommand. The \renewcommand{\BBAB}{og} command does nothing.

\documentclass[11pt]{memoir}
\usepackage[danish]{babel}
\renewcommand{\danishhyphenmins}{22}
\usepackage{apacite}
\usepackage[longnamesfirst]{natbib}
\renewcommand{\BBAA}{&}
\renewcommand{\BBAB}{og}
\begin{document}
\section{Citations}
If I cite \citet{smiths} using the '\citet' command then I get an \& sign rather than 'og'. Of course without it affecting the \citep command and writing 'og' within the parantheses instead of the correct sign \& \citep{smiths}.

\bibliographystyle{apacite}
\bibliography{refs}
\end{document}

Reference in the bib document:
@article{smiths,
author = {Smith, A. and Smith, B.},
journal = {Journal of Apacite},
number = {1},
pages = {24305--36811},
title = {{How do I change \& to 'and'}},
volume = {1},
year = {2014}
}
5
  • It is, is biblatex an option for you?
    – Johannes_B
    Nov 29, 2014 at 16:25
  • I don't understand: do you want that in \citet the & becomes “og” and in \citep it remains &?
    – egreg
    Nov 29, 2014 at 16:28
  • @egreg - The APA requires that & be used for parenthetical citations (à la \citep) and in the bibliography entries, whereas and (or og, or i, ...) must be used for textual citations (à la \citet).
    – Mico
    Nov 29, 2014 at 16:33
  • 1
    @Mico APA requirements are stupid; the & symbol is good for a company name, not for citations.
    – egreg
    Nov 29, 2014 at 16:34
  • @egreg - I fully agree with your evaluation of this requirement. But what choice does a wretched soul have if if he/she must meet these requirements?
    – Mico
    Nov 29, 2014 at 16:41

1 Answer 1

5

I suggest you make the following two changes to your code:

  • First, change

    \usepackage{apacite}
    \usepackage[longnamesfirst]{natbib}
    

    to

    \usepackage[natbibapa]{apacite}
    

    This loads the natbib package in a way that maintains compatibility with apacite. (For more on this, see p. 7 of the user guide of the apacite package.) Using this loading method has the added benefit that natbib is loaded automatically with the option longnamesfirst (see p. 15 of the user guide). In short, don't load the two packages independently.

  • Second, change \renewcommand{\BBAA}{&} to \renewcommand{\BBAA}{\&}, i.e., be sure to "escape" the & symbol.


enter image description here

\documentclass[11pt]{article} %% just to keep everything on one page
\usepackage{filecontents}
\begin{filecontents*}{refs.bib}
@article{smiths,
author = {Smith, A. and Smith, B.},
journal = {Journal of Apacite},
number = {1},
pages = {24305--36811},
title = {How do {I} change \& to `and'},
volume = {1},
year = {2014}
}
\end{filecontents*}
\usepackage[danish]{babel}
\renewcommand{\danishhyphenmins}{22}

\usepackage[natbibapa]{apacite} % <-- new
\bibliographystyle{apacite}
\renewcommand{\BBAA}{\&} % <-- modified
\renewcommand{\BBAB}{og}

\begin{document}
\citet{smiths}

\citep{smiths}
\bibliography{refs}
\end{document}
1
  • 1
    @Faergen - Thank you for posting a very clear MWE. That's what made it straightforward to spot the problems and come up with solutions.
    – Mico
    Nov 29, 2014 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .