4

I am using KOMA-script in lyx for my thesis. I would like to add the page number next to the reference in bibliography. Some thing like this:

  1. S. J. Young, G. Evermann, M. J. F. Gales, T. Hain, D. Kershaw, G. Moore, J. Odell, D. Ollason, D. Povey, V. Valtchev, and P. C. Woodland, The HTK Book, version 3.4. Cambridge, UK: Cambridge University Engineering De- partment, 2006. [3], [15], [21]

The numbers [3], [15], [21] are the pages where the used literature is cited.

My preamble is here:

\usepackage[figure]{hypcap}
%\usepackage{tocbibind}
\usepackage[nottoc]{tocbibind}

% the pages of the TOC is numbered roman
% and a pdf-bookmark for the TOC is added
\let\myTOC\tableofcontents
\renewcommand\tableofcontents{%
  \frontmatter
  \pdfbookmark[1]{\contentsname}{}
  \myTOC
  \mainmatter }

% makes caption labels bold
\setkomafont{captionlabel}{\bfseries}
\setcapindent{1em}

% enables calculations
\usepackage{calc}

% fancy page header/footer settings
\renewcommand{\chaptermark}[1]{\markboth{#1}{#1}}
%\renewcommand{\sectionmark}[1]{\markright{\thesection\ #1}}

\renewcommand{\sectionmark}[1]{\markright{Section \thesection\ #1}}


% increases the bottom float placement fraction
\renewcommand{\bottomfraction}{0.5}

% avoids that floats are placed above its sections
\let\mySection\section\renewcommand{\section}{\suppressfloats[t]\mySection}

\pagestyle{plain} 
\newcommand*{\argmin}{\operatornamewithlimits{argmin}\limits}

The bibliography uses IEEETran.

  • 3
    Try \usepackage[backref=true]{hyperref} – user11232 Nov 30 '14 at 12:45
  • I copied this to preamble but it did not work. I forgot to mention that my Bib style is IEEEtran. Please guide me more! – suribright Dec 1 '14 at 13:01
  • 1
    Then it would be helpful you create a complete (compilable!) minimal working example showing us all relevant parts for your problem and give us the chance to copy your complete on our computers and to play with ... Your used documentclass or loaded packages can be a reson for your problem ... – Mensch Dec 1 '14 at 17:15
  • 1
    @HarishKumar's suggestion should work. After adding the instruction to the preamble, did you remember to recompile fully (latex, bibtex, and latex twice more) to propagate all changes? – Mico Dec 2 '14 at 8:22
  • @Mico: Here is the error after running again and again the file. I dont know what this error is about? The package hyperref has already been loaded with options: [unicode=true] There has now been an attempt to load it with options [backref=true] Adding the global options: unicode=true,backref=true to your \documentclass declaration may fix this. Try typing <return> to proceed. – suribright Dec 3 '14 at 13:24
2

The facility you are requesting is provided by the package hyperref and backref For hyperref you have to say

\usepackage[pagebackref]{hyperref}  

or

\usepackage[backref]{hyperref}

If you ever get any warning like

The package hyperref has already been loaded with options: [unicode=true]

try loading the options via \hypersetup like

\hypersetup{backref}

or add backref to \documentclass options

\documentclass[backref]{article} 

For more details consult the manual of either backref or hyperref package.

\begin{filecontents*}{backref.bib}
@article{Astrm2014,
  doi = {10.1016/j.automatica.2013.10.012},
  url = {http://dx.doi.org/10.1016/j.automatica.2013.10.012},
  year  = {2014},
  month = jan,
  publisher = {Elsevier {BV}},
  volume = {50},
  number = {1},
  pages = {3-43},
  author = {Karl J. {\AA}str\"{o}m and P. R. Kumar},
  title = {Control: {A} perspective},
  journal = {Automatica},
}
\end{filecontents*}

\documentclass{article}
\usepackage{cite}
\usepackage[pagebackref]{hyperref}


\begin{document}

\cite{Astrm2014}

\clearpage
\bibliographystyle{unsrt}
\bibliography{backref}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.