4

I use the \autocite command with the autocite=footnote option for citations. If I use this command to cite a word which is directly followed by a punctuation (most often a comma or period) the superscript is moved to the right of the punctuation.

Consider the following cases:

This is the main sentence with an important word\autocite[][]{ABC12}, followed by a subordinate clause.
This is the main sentence with an important word\autocite[][]{ABC12}.    

will lead to

This is the main sentence with an important word,² followed by a subordinate clause.

This is the main sentence with an important word.³

In general the option autopunct which is responsible for this behavior is useful (for example at the end of a sentence when the citation is for the complete sentence). However in the cases described above or in some similar cases it would be useful to disable the autopunct option temporary only for this time.

Has one of you an idea how to achieve a command like \autociteAP and \autocitesAP (for an autocite command with a disabled autopunct option) or how to give a parameter noautopunct to the normal \autocite(s) command?

4

The easiest thing is just to add an empty pair of braces after the command and before the punctuation:

\autocite[][]{bertram}{},

Sample output

\documentclass{article}

\usepackage[autocite=footnote]{biblatex}

\addbibresource{biblatex-examples.bib}

\begin{document}

This is the main sentence with an important word\autocite[][]{bertram}{},
followed by a subordinate clause.  This is the main sentence with an
important word\autocite[][]{bertram}{}.

This is the main sentence with an important word\autocite[][]{bertram},
followed by a subordinate clause.  This is the main sentence with an
important word\autocite[][]{bertram}.


\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.