3
\starttypescript[serif]                    [titillium]
    \definefontsynonym[Serif]            [file:Titillium-Regular]
    \definefontsynonym[SerifBold]            [file:Titillium-Bold]
    \definefontsynonym[SerifItalic]            [file:Titillium-Italic]
    \definefontsynonym[SerifBoldItalic]        [file:Titillium-Bold-Italic]
\stoptypescript

\starttypescript[sans]                    [titillium]
    \definefontsynonym[Sans]            [file:Roboto-Regular]
    \definefontsynonym[SansBold]            [file:Roboto-Bold]
    \definefontsynonym[SansItalic]            [file:Roboto-Italic]
    \definefontsynonym[SansBoldItalic]        [file:Roboto-Bold-Italic]
\stoptypescript

\starttypescript[calligraphy]                [titillium]
    \definefontsynonym[Calligraphy]            [file:Arizonia-Regular]
\stoptypescript

\starttypescript[handwriting]                [titillium]
    \definefontsynonym[Handwriting]            [file:Pacifico-Regular]
\stoptypescript

\starttypescript[titillium]
    \definetypeface[titillium]                [rm][serif][titillium][default]
    \definetypeface[titillium]                [ss][sans][titillium][default]
    \definetypeface[titillium]                [cg][calligraphy][titillium][default]
    \definetypeface[titillium]                [hw][handwriting][titillium][default]
\stoptypescript


\usetypescript[titillium]
\setupbodyfont[titillium, 12pt]

\starttext

    \startitemize
        \item This is an item.
        \item This is another item.
    \stopitemize
\stoptext

When I compile this, it reports:

tex error > error on line 38 in file /tmp/test.tex: ! Math error: parameter \Umathquad\displaystyle is not set

  • If I change the bulleted list to an enumerated list, e.g. \startitemize[2] changed to \startitemize[n], then it compiles fine.
  • If I change the bulleted list to default list, e.g. \startitemize[2] changed to \startitemize, then it similarly fails to compile, reporting the same error.
  • If I instead keep the bulleted list, but delete the custom typescript, it compiles fine.
  • I tried switching all of the fonts to entirely different fonts, but it similarly failed to compile.

How can I compile the document with custom fonts and a bulleted list?

  • Please provide a complete MWE that we can compile to reproduce the problem, as it is, this is just a code snippet. People will be more willing to assist if they don't have to recreate the document (and assume packages, etc) themselves. – penguinpreferred Dec 2 '14 at 23:40
  • I don't understand. I already provided a minimum working example. I do not add any packages. If I copy that code into a blank file, then compile it, it does not compile, reporting the error I listed. – Village Dec 3 '14 at 4:27
  • 5
    The bullet points for the items are taken from the math font but you don’t set one in your document. When you add \definetypeface [titillium] [mm] [math] [modern] [default] to your typescripts the error message will disappear. – Wolfgang Schuster Dec 3 '14 at 10:41
  • but that approach will only load one font file, not two. I just don't see the common sense in it. I would expect to have the two files available, not one. – doed Dec 5 '14 at 11:53
  • When I load Latin Modern as math font two fonts are used in the document which are latinmodern-math.otf and titillium-regular.otf. When the Titillium font doesn’t exist on your system ConTeXt will use Latin Modern also for the text in the itemize. – Wolfgang Schuster Dec 6 '14 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.