4

It seems I'm having a lot of issues with using the ieeetran class in Lyx. Currently the word "Table" appears instead of "TABLE".

Each of the letters is supposed to be capitalized, but right now just the T is.

I have it set the Document Class to "IEEE Transactions" and custom to journal. in the document as follows: enter image description here

I am also just using a LyX file by created a new file from an IEEEtran template they have built into LyX.

However, my table title looks like this still:

enter image description here

I'm wondering if there is an underlying problem that I haven't taken care of because I was experiencing the same problem with my figures. The figures would be captioned as "Figure 1" instead of "Fig. 1.", which is the appropriate way for IEEE Transactions.

===== UPDATE 1: =====

It seems like a temporary solution is to do the following: Add the following ERT (Latex code) to EVERY table float: \def\tablename{TABLE} I tried adding it to the preamble, and even using the \renewcommand\tablename{TABLE} command in the preamble, but neither worked. I'm assuming the same is true regarding figures, but adding \def\figurename{Fig.} in each figure float to get Fig. 1 instead of Figure. I solved that issue in a different way though, if you see my previous questions.

3

Make sure that you also remove the use of babel in your preamble. That is, under Document > Settings... > Language, select None in terms of the language package to use:

enter image description here

babel adapts caption titles depending on the language, which is something you don't want in this case.

  • THANK YOU! This also fixed the "Figure 1" problem I was having. So I can remove my temporary fix I had for that too. What is the purpose of Babel? – Veridian Dec 3 '14 at 19:17
  • @sphere: babel provides language support and hooks for a variety of elements in your document (captions for floats, LoT/LoF/ToC header entries, Chapters and hyphenation patterns for foreign languages, ...). – Werner Dec 3 '14 at 19:23
  • I reported it in the Lyx Bug Tracker. – Veridian Dec 3 '14 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.