0

I clean-installed Mavericks and now tried to install MacTex.

I tried 1. downloading the MacTeX.pkg from http://www.tug.org/mactex/index.html 2. downloading from mirrors [http://www.tug.org/mactex/mirrorpage.html] 3. using Safari 7 and Safari 5. 4. changing permissions and ownership [me: read & write, me: owner]

I always get: Installer: "The Installer is damaged. The Installer can’t open the package. There may be a problem with file ownership or permissions." Installer log: "Dec 3 14:42:24 Js-MacBook-Pro.local Installer[782]: Install's runner tool is not properly configured as a setuid tool. Dec 3 14:42:24 Js-MacBook-Pro.local Installer[782]: Unable to create InstallController"

None of the related threads could help me.

  • This sounds like a problem related to the MacOSX installer app, rather than something caused by MacTeX. Have you considered posting this query to apple.stackexchange.com? – Mico Dec 3 '14 at 21:29
  • This is a rare occasion where using Disk Utility to fix permissions might help, if runner is actually not configured setuid. $ ls -l /System/Library/PrivateFrameworks/Install.framework/Versions/A/Resources/runner -rwsr-sr-x 1 root wheel 120320 Sep 24 15:55 /System/Library/PrivateFrameworks/Install.framework/Versions/A/Resources/runner* – Adam Maxwell Dec 7 '14 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.