4

I'm glossing long lines of text with the expex package. When the glwords wrap to a new line, there doesn't seem to be any space added. For a large block of text it helps to have a little space there. I am able to get more or less what I want by adding a strut in the first lines, but of course this adds a little vertical space above the very first line as well.

\documentclass{book}
\usepackage{expex}
\begin{document}
Default spacing:

\ex \begingl
\gla Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nam consectetuer mollis dolor.// 
\glb Sed dolor. Praesent a lacus vitae turpis consequat semper. Duis sem velit,//
\endgl\xe

Desired spacing (almost):

\ex[everygla={\it\rule{0pt}{20pt}}] \begingl
\gla Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nam consectetuer mollis dolor.// 
\glb Sed dolor. Praesent a lacus vitae turpis consequat semper. Duis sem velit,//
\endgl\xe
\end{document}
  • Can you post a complete minimal document with an example? – Alan Munn Dec 4 '14 at 5:35
5

There's a parameter for this: extraglskip (see §11.3 of the docs):

\documentclass{book}
\usepackage{expex}
\begin{document}
Default spacing:

\ex \begingl
\gla Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nam consectetuer mollis dolor.// 
\glb Sed dolor. Praesent a lacus vitae turpis consequat semper. Duis sem velit,//
\endgl\xe

Desired spacing?

\ex[extraglskip=!.75ex] \begingl
\gla Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nam consectetuer mollis dolor.// 
\glb Sed dolor. Praesent a lacus vitae turpis consequat semper. Duis sem velit,//
\endgl\xe
\end{document}

output of code

  • That is indeed the solution. I was aware of that parameter but it was producing the wrong behavior in my actual file. With some further investigation it appears that the extraglskip parameter produces unexpected results (space above and below the first line) when the word ends in a meem (U+0645). I am sending a MWE to the developer. I'll send it to you as well if you're interested. Thanks. – adam.baker Dec 4 '14 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.