2

I installed a new font using Font Book on my mac. But when I try using fontspec, I get an error that says "font-not-found". It seems that the name that appears in the Font Book application is not the same as the files for the font that were installed, but I tried different names and it still doesn't seem to be able to load. When I select "show in finder" in Font Book, it shows me that the files are stored in ~/Library/Fonts. Any ideas on why fontspec is having issues?

The font is called "Fontin," and I downloaded it from http://www.exljbris.com/fontin.html There seem to be several files that correspond to Fontin in ~/Library/Fonts, which include Fontin_19.suit, FontiReg, FontiSmaCap.

\documentclass{article}

\usepackage{fontspec}
\setmainfont[SmallCapsFont = Fontin SmallCaps]{Fontin} 

\begin{document}

The quick brown fox jumped over the lazy dog.

\end{document}
  • 1
    Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – cfr Dec 6 '14 at 2:45
  • What's the name of the font and of the file that contains the font? With which instruction do you try to load the font? – Mico Dec 6 '14 at 8:04
  • 1
    The error you see regarding mktexmf is misleading. XeTeX first tries system fonts; if it doesn't find the requested one, the standard mechanism based on building the font from Metafont sources pops in. In your case it just means XeTeX is not able to find the system font. What's its name? – egreg Dec 6 '14 at 8:46
  • @egreg I added a few details to the question. – asperanz Dec 6 '14 at 21:55
  • You should look at the font name corresponding to FontiSmaCap by getting info from Font Book. – egreg Dec 6 '14 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.