3

I have used hyperref (with xcolor) and

\hypersetup{
  linkcolor=black,
  filecolor=black,
  urlcolor=black,
  citecolor=black
}

for quite some time now. However, in a coloured text this looks somewhat silly. Is there a (simple) way to turn of link colours completely? I also do not want these (mostly red) boxes, the links should just look as normal text.

8
  • Have you tried hidelinks?
    – Johannes_B
    Commented Dec 6, 2014 at 14:56
  • 1
  • @Johannes_B: Thanks, that helped a lot. Sadly, In Tex Live 2009 (Ubuntu 12.04) the option hidelinks is not present, but there is a helpful answer nevertheless.
    – Keba
    Commented Dec 6, 2014 at 15:08
  • TeX Live is sooo old, i recommend to make an update before starting your next project.
    – Johannes_B
    Commented Dec 6, 2014 at 15:09
  • 3
    Options hidelinks, allcolors, allbordercolors were added in version 2011-02-05 v.6.82a. Commented Dec 6, 2014 at 15:11

2 Answers 2

4

Maybe you can use the current color . defined by the xcolor package:

\documentclass{article}
\usepackage{xcolor}
\usepackage{hyperref}
\hypersetup{colorlinks,linkcolor=.,filecolor=.,urlcolor=.,citecolor=.}

\begin{document}
\section{Section}\label{test}
{\color{blue}See \ref{test}},
{\color{orange}see \ref{test}}, 
see \ref{test} 
\end{document}

enter image description here

1
  • This is helpful, although it should be noted, that for newer versions than Tex Live 2009 there are better options (see the comments above).
    – Keba
    Commented Dec 7, 2014 at 18:04
0

If you insist on keeping texlive 2009, install a new hyperref, e.g. from here: http://www.ctan.org/pkg/hyperref

You can install into your ~/texmf, and if it doesn't work, simply remove it again. Watch out, if your ~/texmf includes a file ls-R, you have to update it, say texhash ~/texmf.

1
  • It is easiest if the OP installs using the .tds.zip file.
    – jon
    Commented Dec 6, 2014 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .