4

I have been using the garamondx font package with pdflatex to typeset my CV for years without any problems. During my latest round of keeping it up to date, suddenly ligatures no longer want to typeset. MWE:

\documentclass[11pt]{article}

\usepackage{garamondx}

\begin{document}
Sufficiently pacific
\end{document}

Result (copied from the resulting PDF):

Su`ciently paci∏c

I would argue that this is clearly incorrect. I have tried looking at the documentation, which suggests the addition of \usepackage[full]{textcomp} before loading, but that doesn't have any effect. I've tried using fontenc to change the font encoding, but always get the same result. I also tried uninstalling and reinstalling the package, but to no avail.

Every other font I've tried gets the ligatures correct. I've also tried the ebgaramond and garamond packages, but these versions of Garamond are too heavy for my taste.

Has anyone else observed this behavior? I'm using MikTeX on Windows 7


When I add \listfiles to beginning of the MWE above, the log file contains the following garmondx-related lines:

("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\garamondx\garamondx.sty"
Package: garamondx 2014/10/08 v1.092

`garamondx' v1.092. 2014/10/08 GaramondNo8 with expert features (Michael Sharpe
)

...

LaTeX Font Info:    Try loading font information for T1+zgmx on input line 7.

("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\garamondx\t1zgmx.fd"
File: t1zgmx.fd 2012/10/29 Fontinst v1.933 font definitions for T1/zgmx.
)
("C:\Users\craigim\Documents\My Dropbox\LaTeX\Projects\GaramondMWE.aux")
LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 7.
LaTeX Font Info:    ... okay on input line 7.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 7.
LaTeX Font Info:    ... okay on input line 7.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 7.
LaTeX Font Info:    ... okay on input line 7.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 7.
LaTeX Font Info:    ... okay on input line 7.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 7.
LaTeX Font Info:    ... okay on input line 7.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 7.
LaTeX Font Info:    ... okay on input line 7.
LaTeX Font Info:    Checking defaults for TS1/cmr/m/n on input line 7.
LaTeX Font Info:    Try loading font information for TS1+cmr on input line 7.
 ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\ts1cmr.fd"
File: ts1cmr.fd 2014/09/29 v2.5h Standard LaTeX font definitions
)
LaTeX Font Info:    ... okay on input line 7.
 ("C:\Program Files (x86)\MiKTeX 2.9\tex\context\base\supp-pdf.mkii"
  • I get the same. However, I see an update is available. I'm currently in the process of installing that, so fingers crossed ;). – cfr Dec 6 '14 at 22:39
  • But it doesn't... :(. – cfr Dec 6 '14 at 22:42
  • Why on earth does it require graphicx for god's sake? – cfr Dec 6 '14 at 22:45
  • 1
    @cfr I don't think getnonfreefonts can uninstall fonts. Do it manually and always use getnonfreefonts-sys (as super user). – egreg Dec 6 '14 at 23:45
  • 1
    @Bernard Can you explain how to do this for MiKTeX? I've given instructions for TeX Live... – cfr Dec 7 '14 at 0:32
4

Return of the Ligatures

The current package works. The current installation script apparently screws up and fails to uninstall all of the old version. I suspect this is because the tds file for the package is apparently somewhat messy but, also, because getnonfreefonts-sys mistakenly assumes that the packages it installs will be well-behaved. But the current installation still leaves a mess - just it leaves a working mess, rather than a non-working one which is improvement, of a sort.

These instructions should work for TeX Live. Somebody will hopefully modify them for MiKTeX.

Switch to the user you use to manage your local texmf tree. (This will be root on many systems. Be very careful, if yours is among them!)

cd $(kpsewhich --var TEXMFLOCAL)
pwd

Make sure you really have switched directories.

Make a temporary directory somewhere if you would prefer to move files rather than removing them [recommended].

mkdir ../garamondx-incase

It should not be in the directory you are currently in or in any sub-directory of that directory.

updmap-sys disable zgm.map

Now you want to move all traces of garamondx from this directory tree to your 'incase' directory:

fonts/afm/public/garamondx
fonts/afm/urw/garamondx
fonts/enc/dvips/dvips/garamondx
fonts/enc/dvips/garamondx
fonts/map/dvips/dvips/garamondx
fonts/map/dvips/garamondx
fonts/tfm/public/garamondx
fonts/tfm/urw/garamondx
fonts/type1/public/garamondx
fonts/type1/urw/garamondx
fonts/vf/public/garamondx
fonts/vf/urw/garamondx
source/fonts/garamondx
src **** CHECK CONTENTS FIRST ****
tex/latex/garamondx

[If you think I've missed something, please let me know.]

mktexlsr $(kpsewhich --var TEXMFLOCAL)

getnonfreefonts-sys -f garamondx

Make garamondx behave slightly more civilly:

mkdir -p $(kpsewhich --var TEXMFLOCAL)/source/fonts
mv $(kpsewhich --var TEXMFLOCAL)/src $(kpsewhich --var TEXMFLOCAL)/source/fonts/garamondx
mktexlsr $(kpsewhich --var TEXMFLOCAL)

[If I've missed something, let me know! The combination of a messy garamondx and an insufficiently careful script makes for one very, very badly behaved thing.]

Be careful. It is a mess. Note, too, that the .sty file is problematic, as well, although it does work. It is loading completely irrelevant packages, as well as using document-level commands.

  • I am not 100% sure what the necessary steps were, but I uninstalled all fonts with the string "garamond" in either the package name or description, then I had to go in and erase a bunch of empty directories, then I reinstalled garamondx and the final coup de grace was to run updmap. With that, your test sentence hits all the correct ligatures and more importantly, my CV compiles without error. Thanks for all your help! – craigim Dec 7 '14 at 17:55
  • Well I can confirm that after an update with getnonfreefonts garamondx in texlive was messed up. Happily in my case (as I had used getnonfreefonts instead of getnonfreefonts-sys and have my local files elsewhere) the fonts where alone in TEXMFHOME and I could simply delete the tree and reinstall. In miktex everything worked out-of-the box. Did you inform the texlive team and the author of garamondx about the problem? – Ulrike Fischer Dec 8 '14 at 9:24
  • @UlrikeFischer I emailed the author about both the misplacement of the source (which doesn't stop anything working but is non-TDS) and this issue, but I think this issue is possibly not the package author's fault, He said that he uses public whereas the CTAN packager uses urw (but not now?), and that the latter never answers his emails. I'm not sure who the right person to contact about it is. (The TDS stuff will get cleaned up and so will the style file, I think, but the issue causing stuff to break seems to depend on several people and I can't disentangle them!) – cfr Dec 8 '14 at 13:37
  • 1
    @UlrikeFischer I just got a notification in my CTAN RSS feed that the garamondx package has been updated to v1.093a with the announcement text: "Corrections to paths in source folder of tds, plus added instructions in README for removing previous version prior to updating." – craigim Dec 10 '14 at 17:19
  • @craigim I tried the update and the ligature problem is still there. :-( – egreg Dec 13 '14 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.