2

I recently had to upgrade my LyX distribution to remain compatible with a LyX distribution on a different machine. When I upgraded (2.0.6 to 2.1.3), I was no longer able to generate preview PDFs. I am still learning the program, and it is not clear to me if I need to redirect the paths for certain actions. Comparing the preferences across distributions (my old distribution was not overwritten, and I can still push to PDF from it), there does not seem to be a noticeable difference. On the new distribution, I get the following error in the terminal when I attempt to preview:

No protocol specified

** (evince:21375): WARNING **: Could not open X display
No protocol specified
error: XDG_RUNTIME_DIR not set in the environment.
Cannot parse arguments: Cannot open display: 

Has anyone encountered this before? The questions that I have seen related to this issue don't seem to match my problem specifically, so any help would be greatly appreciated.

UPDATE: In response to a comment below, here is quick test of evince.:

user:~/dissertation$ evince 02-10-revenueprojections.pdf 
Syntax Warning: parseAction: Unknown annotation action object: URI = 'NULL'
Syntax Warning: parseAction: Unknown annotation action object: URI = 'NULL'

** (evince:22388): WARNING **: Unimplemented annotation: POPPLER_ANNOT_STAMP.  It is a known issue and it might be implemented in the future.

Despite the warning, the PDF opens just fine.

  • 1
    From the error it appears that launching evince is the problem. I'm unclear from your description. Can you open any PDF with evince (e.g. by double clicking on a file in your file manager program such as nautilus)? Have you checked the temporary files directory to see if the PDF is generated correctly? – penguinpreferred Dec 7 '14 at 4:58
  • Thanks for checking in. Evince is working just fine it seems. The problem seems isolated to the upgraded version of LyX. The old version still works, which is why I was wondering about updating of paths. – Marvin Ward Jr Dec 7 '14 at 14:33
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Dec 7 '14 at 21:59
  • There is something wrong if XDG_RUNTIME_DIR is not set and you are in a GUI environment on a GNU/Linux system set up in a reasonably standard way. Moreover, this is likely to cause other issues, although how serious they are will depend on what exactly is wrong. But this is a symptom, not a cause. (And it has nothing to do with TeX.) – cfr Dec 8 '14 at 0:52
  • This is the first time I have had an issue on this front. I would appreciate if you could elaborate... – Marvin Ward Jr Dec 8 '14 at 0:55
0

Not sure this is the best solution in the world, but I just replaced evince as the preferred PDF reader.

Tools > Preferences > File Handling > File Formats

I selected the PDF(pdflatex) format, and changed the viewer from evince to xpdf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.