1

This is my first time using LyX to write my thesis.

Running on Mac (OSX 10.9) and downloaded LyX Version 2.1.1.

I noticed that there is no installer. All LyX files are bundled here:

(1) /Applications/LyX.app/

Below (where LyX looks in for templates) is empty:

(2) /Library/Application Support/LyX-2.1/

So, I copied relevant files from (1) to (2).

Now, LyX sees the templates.

But, LyX complains that I am missing template prerequisites when I try to load them.

For example, I tried to load this template:

https://ccrma.stanford.edu/~dtyeh/thesistemplate.html

I got:

"Document cannot be compiled until the following prerequisites are installed: report.cls"

Similar flags are thrown for the other default Lyx templates.

How and where do I get these template prerequisites?

I have MacTex installed.

I must be missing something: it should not be this hard.

Thanks!

Lance

  • Have you tried reconfiguring (Tools → Reconfigure) LyX? – DG' Dec 7 '14 at 13:33
  • That works for the thesis template I was trying to load. Great, thanks. However, other default LyX templates still have missing templates (e.g., Hollywood.lyx requires Hollywood.cls). Just in case I need to use other templates with currently missing prereqs, where would I get these missing .cls files (it may differ for each, I realize) and where would I put them? – lmart999 Dec 7 '14 at 17:07
  • It does not sound at all right if you are manually copying files from inside the .app elsewhere. Either this is a bug in the software, and should be reported, or you have misunderstood something somewhere. Note that whereas report.cls is a standard file provided by TeX Live (e.g. MacTeX), Hollywood.cls certainly is not. I've never heard of it and have no clue where you would find it. It is not on CTAN. The only thing you can do in this case is search the web. – cfr Dec 7 '14 at 19:21
  • Re: templates (e.g., Hollywood.cls). Got it. – lmart999 Dec 8 '14 at 7:11
  • Re: manual copy from .app. Agreed, this didn't seem right. I came across a thread reporting my problem (no templates included) when using the Mac alias to the Applications folder. There appears to be no installer program provided, but - as mentioned below - perhaps simply "Reconfigure" would have solved this? lyx.475766.n2.nabble.com/… – lmart999 Dec 8 '14 at 7:20
2

To make LyX aware of installed packages, run reconfigure (Tools → Reconfigure).

If you need another package that is required by LyX and not provided by MacTeX, install it in ~/Library/texmf or /usr/local/texlive/texmf-local.

If you choose to install in /usr/local/texlive/texmf-local, you will need to run mktexlsr /usr/local/texlive/texmf-local in order for TeX to find the files. If you install in ~/Library/texmf, this is not necessary.

Don't forget to reconfigure LyX again.


As @cfr already pointed out: do not copy stuff from the application package to some place else. Instead do a clean install of LyX (remove the App with AppTrap or a similar tool if necessary) and MacTeX. Aaand reconfigure LyX.

0

The LyX file collection includes several files that are not placed into the correct position to be found by the LyX program itself on the Macintosh. It actually IS necessary to move the template files into a place where LyX is looking for them. Or else they are not found when a user runs File/New from template.

This is a long standing LyX problem (see http://lyx.475766.n2.nabble.com/Mac-OSX-LyX-Install-No-templates-included-td478050.html). I don't know why it has been left unattended so long. I just help students with LyX on Macs, I have become aware of this now-and-then, but forget between times.

Mac is the only system on which you install LyX and try File/new from template, you find nothing. If the problem were missing LaTeX packages, you would see the template files listed, but they would not open without complaint. The LyX application folder contains the template files you need. That post from 2008 claims that there are actually several directories you need to copy out of the LyX folder into another place (where depends on if you are root or not).

It is NOT actually necessary to reinstall LyX and I do not believe it should even be necessary to reconfigure. As long as you install mactex BEFORE you install LyX, then LyX will have already run the configure step and it will be aware of the fact you have most packages. I can certify from today's experience that the LyX APA6 template file does compile with the base mactex install and LyX 2.1.3. LyX Reconfigure (and restart) is needed only if you install more LaTeX packages. Since the mactex package includes 2.5GB of packages, it has almost everything needed to compile most of the templates. (Not all, but many).

I've filed a request with the LyX folks to see if they can improve their packaging for Macs or at least write out the minimally necessary steps for system administrators and individual users to make this correct. http://www.lyx.org/trac/ticket/9499

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.