1

This is a follow-up of my previous question regarding loading image using latex command. @erik kindly informed me that latex only supports images in eps format. I converted my JPG file to an eps file using bmeps.exe in the miktex/bin directory. I can see the image in the dvi file generated by latex. But the original color image in the JPG file becomes a black-white or gray scale image in the eps file. Is it possible to get a color image in eps format using bmeps.exe? Does latex support color image?

A minimum woking example can be found here.

7
  • 1
    Why, why, why do you convert jpg to eps and then use dvi mode? What advantage do you hope to get?
    – Johannes_B
    Dec 8 '14 at 13:47
  • Thanks for the question. I am submitting a paper to arxiv.org. It requires me to submit the source file because the pdf generted by pdflatex is not allowed. The arxiv site only use 'latex' and it does not load image in JPG format. So I have to convert the images to eps format so that they can be loaded into arxiv site. If there is a better and easy way to get paper accepted by arxiv.org, please let me know.
    – mike
    Dec 8 '14 at 14:17
  • 1
    Quote from the website: arXiv fully supports and recognizes PDFLaTeX.
    – Johannes_B
    Dec 8 '14 at 14:49
  • @Johannes_B. Thanks a lot for the info. When I first submitted the .pdf file generate by pdflatex. It did not work. Maybe I am missing the flag (\pdfoutput=1). Arxiv website also mentioned that "You can ensure pdflatex processing by setting \pdfoutput=1 within the first 5 lines of the preamble of the main pdflatex file". Where should I do it? in the .tex file?
    – mike
    Dec 8 '14 at 14:55
  • 1
    If i understood them correctly, you shall send them the tex-files. All of them, along with the figures. Not the final pdf-output.
    – Johannes_B
    Dec 8 '14 at 14:58
1

Looking at the output of bmeps -h on the terminal, we see the following options:

bmeps [options] [ <inputfile> [ <outputfile> ] ]

      Options
      -------

      -p <pslevel>           select one of the following
         1                   (PS level 1)
         2                   (PS level 2 = default)
         3                   (PS level 3)
      -b                     BoundingBox file only
      -c                     turns color printing on
      -g                     turns color printing off (default)
...

So, you need to add the -c option to your command:

bmeps -c filename.jpg filename.eps
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.