4

My Acer Chromebook C720 is running Ubuntu 14.04. (I installed Ubuntu/ChrUbuntu using the script found at link.)

I wanted to install "vanilla" TeX Live rather than the version in the Ubuntu software repository. And so I followed the instructions found in this answer to the question How to install "vanilla" TeXLive on Debian or Ubuntu?

Unfortunately, I ran into the following error when installing the "fake" package to make Ubuntu think it has installed TeX Live:

$ sudo dpkg -i texlive-local_2014-1_all.deb
dpkg: regarding texlive-local_2014-1_all.deb containing texlive-local:
 texlive-base conflicts with texlive-common
  texlive-local provides texlive-common and is to be installed.

dpkg: error processing archive texlive-local_2014-1_all.deb (--install):
 conflicting packages - not installing texlive-local
Errors were encountered while processing:
 texlive-local_2014-1_all.deb

How should I proceed?

  • Do you already have another install on the computer? – jon Dec 8 '14 at 21:14
  • I am working with a fresh installation of Ubuntu. – I Like to Code Dec 8 '14 at 21:15
  • Do you have texlive-base installed? You need to remove it. (You might have installed it as a dependency without realising it.) – cfr Dec 9 '14 at 1:56
  • @cfr You're right! Somehow texlive-base was automatically installed. – I Like to Code Dec 9 '14 at 16:39
4

User cfr pointed out that I may already have texlive-base installed. To check whether this was indeed the case, I listed the installed packages with the name "texlive*".

$ dpkg -l | grep texlive
ii  texlive-base                  2013.20140215-1                                     all          TeX Live: Essential programs and files
ii  texlive-binaries              2013.20130729.30972-2build3                         amd64        Binaries for TeX Live
ii  texlive-fonts-recommended     2013.20140215-1                                     all          TeX Live: Recommended fonts
ii  texlive-generic-recommended   2013.20140215-1                                     all          TeX Live: Generic recommended packages
ii  texlive-latex-base            2013.20140215-1                                     all          TeX Live: LaTeX fundamental packages
ii  texlive-latex-recommended     2013.20140215-1                                     all          TeX Live: LaTeX recommended packages

I then uninstalled all the "texlive*" packages

sudo apt-get purge texlive*

The installation now works as expected.

$ sudo dpkg -i texlive-local_2014-1_all.deb
Selecting previously unselected package texlive-local.
(Reading database ... 166027 files and directories currently installed.)
Preparing to unpack texlive-local_2014-1_all.deb ...
Unpacking texlive-local (2014-1) ...
Setting up texlive-local (2014-1) ...
  • Don't forget to create symbolic links – subham soni Dec 9 '14 at 16:51
  • @subhamsoni I don't recommend doing it. – egreg Dec 9 '14 at 17:08
  • @egreg Why don't you recommend creating symbolic links? The answer to tex.stackexchange.com/q/1092/7142 recommends creating these links using the command sudo ln -s /usr/local/texlive/2014/bin/* /opt/texbin – I Like to Code Dec 9 '14 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.