2

EDIT:after fixing the first problem with Harish Kumar's renewcommand, this problem came up: enter image description here

I have a problem with the "white spaces" which are produced in the bibliography. I've found a couple of answers but i had the mentioned packages in my preamble before. So those answers wouldn't help. i use \usepackage{url} etc.

The strange thing about my problem is, that it only appears in one entry. i checked a dozen times if there are any differences, but i couldn't find anything. I'm not sure if my MWE will help because there is no white space in there.

enter image description here

Here's the link for the download of the .bib file for the entries and .bst for the bibstyle. https://www.dropbox.com/sh/09rewicos64zek6/AACFnng5VBKi2r7KP8W99ZvDa?dl=0

Here's my MWE (problem about the MWE, it works):

\documentclass{scrreprt}
\usepackage[english, ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{natbib}
\usepackage{url}
\setlength{\bibhang}{0mm}
\bibpunct{(}{)}{;}{a}{}{,~}

\begin{document}

\chapter{it doesn't work yet}
blabla \cite{Berger2012}\\
blabla \cite{Klein2013}\\
blabla \cite{Keilig2002}\\
blabla \cite{Jahn2013}\\

\setlength{\bibsep}{2ex plus2ex minus.5ex}
\bibliographystyle{iwbdiss_2} 
\bibliography{literaturverzeichnis}  

\end{document}
  • 1
    Would adding \renewcommand{\UrlBreaks}{\do\a\do\b\do\c\do\d\do\e\do\f\do\g\do\h\do\i\do\j\do\k\do\l\do\m\do\n\do\o\do\p\do\q\do\r\do\s\do\t\do\u\do\v\do\w\do\x\do\y\do\z\do\A\do\B\do\C\do\D\do\E\do\F\do\G\do\H\do\I\do\J\do\K\do\L\do\M\do\N\do\O\do\P\do\Q\do\R\do\S\do\T\do\U\do\V\do\W\do\X\do\Y\do\Z\do\1\do\2\do\3\do\4\do\5\do\6\do\7\do\8\do\9\do\/\do\-\do\_\do\:\do\.} in the preamble help? – user11232 Dec 10 '14 at 14:37
  • ^^YES, thanks! first when i copied it into the preamble it didn't work. copy/ paste puts four question marks into your command, for no reason. after deleting those question marks it works fine!!! – goodstuff Dec 10 '14 at 15:07
5

You can make url to break the lines at places you want by adding these lines to your preamble:

\renewcommand{\UrlBreaks}{\do\a\do\b\do\c\do\d\do\e\do\f\do\g\do\h\do\i\do\j\do‌​\k\do\l\do\m\do\n\do\o\do\p\do\q\do\r\do\s\do\t\do\u\do\v\do\w\do\x\do\y\do\z\do\‌​A\do\B\do\C\do\D\do\E\do\F\do\G\do\H\do\I\do\J\do\K\do\L\do\M\do\N\do\O\do\P\do\Q‌​\do\R\do\S\do\T\do\U\do\V\do\W\do\X\do\Y\do\Z\do\1\do\2\do\3\do\4\do\5\do\6\do\7\‌​do\8\do\9\do\/\do\-\do\_\do\:\do\.}

This should solve the problem of url not being able to split the word Serienproduktion in your url.

  • Do you have any additonal solutions? The problem that you see in the picture looks great. But sadly another url in my bib has a white space at the end of the line. The word that gets split is: /Vibromet ers/OFV So the used letters are within the renewcommand :( I'll add a picture so it's clear. – goodstuff Dec 10 '14 at 16:24
  • @goodstuff: ` [obeyspaces,spaces]` option is responsible for allowing line break at spaces. If you have enabled it, remove. – user11232 Dec 10 '14 at 23:07
  • the only thing i've enabled is \usepackage{setspace}. the line break is not set at a space, is it? it's in between the url and the word "Vibromet \\ers" – goodstuff Dec 11 '14 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.