1

I'm using the glossaries and hyperref packages, and my document has 10 or so pages of frontmatter, in roman numerals.

All the links in the glossary have the correct page numbers, but when you click them they go to the wrong page. They go to the side of that number, but they fail to include the frontmatter in the count, so are offset,

E.g. an acronym used on page 20, in a document with 10 pages of frontmatter, will link to the side numbered 10 in the pdf.

How can I fix this? I'm using MacTeX-2010.

Edit:

\documentclass[twoside]{book}

\title{A LaTeX Article}
\author{Your name here}
\date{2011-06-27}

\usepackage{hyperref}
\usepackage[acronym]{glossaries}
\makeglossaries

\begin{document}
    \newacronym{www}{WWW}{World Wide Web}
    \newacronym{http}{HTTP}{HyperText Transfer Protocol}
    \frontmatter

    \maketitle

    \tableofcontents

    \printglossaries

    \mainmatter

    \chapter{Introduction}
    The \gls{www} is big.

    \chapter{Next}
    The \gls{www} works over \gls{http}.
\end{document}
4

In creating the example above, I found it worked.

In my situation I'm using a custom style, which had set the hypertexnames=false option to the hyperref package. I replaced that with plainpages=false and pdfpagelabels which fixed it.

  • How did you fix the problem of broken links to floats as described here: tex.stackexchange.com/questions/35888/… – Simon Nov 23 '11 at 12:45
  • 1
    This is my full set of hyperref args, incase that helps: \usepackage[pdfpagemode={UseOutlines},bookmarks=true,bookmarksopen=true, bookmarksopenlevel=0,bookmarksnumbered=true,plainpages=false, colorlinks,linkcolor={blue},citecolor={blue},urlcolor={red}, pdfstartview={FitV},unicode,breaklinks=true,pdfpagelabels,pagebackref]{hyperref} – Lethargy Nov 29 '11 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.