I just recently updated Miktex via the update wizard, and after that LuaLaTeX fails to generate any output. At first I thought it would have to do something with SIunitx, because I received an error there and it was used in the file I tried to employ LuaTeX on (SIunitx, was located into another package I think), but that wasn't the case. (SIunitx still doesn't work, because MiKTeX reports

"Message: Unknown archive file size.
Data: expl3
Source: libraries\miktex\packagemanager\internal.h

when I try to get expl3 via the package manager.

Anyway, I then tried to use as few packages as possible to rule out some incompatibilities introduced by the new update or something like that, and tried to use LuaLaTeX on the following file:


And all I get is

This is LuaTeX, Version beta-0.70.1-2011052811 <rev 4277>

<Fatal format file error; I'm stymied>

No log-file, no output, nada, only this error message. pdfTeX and the latex-dvips-ps2pdf-way both work without any problems (at least on the above file).

I could really use some help, since everything worked just fine about two weeks ago until my last update.

Please let me know if you want to get further information or anything like that to help me with my problem.

Oh, I almost forgot (in case it's important):

OS: Windows Vista Home Premium (32bit),

MiKTeX 2.9 (just updated :/)

I don't know whether I should make another separate question out of this, but I've got another problem with luatex, but only indirectly. I think I already know the cause, so I, more or less, just want to verify whether this is an issue of my own local installation, or a "global" problem:

Not a long time ago, there was another MiKTeX-Update, so I updated. But then I tried to compile another document with lualatex that worked before, but lualatex didn't create a document at all, while not reporting any real problems (at least not via Texmaker). So I looked into the folder of the file, and voila, lualatexor luatex(:O) created a folder, named "luatex-cache" and a log file, but nothing more. I then tried to isolate the problem by making a minimal example and first found out, that it probably isn't a luatex-problem itself, since sth. like:


was compiled without any problems. I then continuously added more packages and I think the troublemaker could be luatextra. Again, the only output of


was: a folder named "luatex-cache" with an empty subfolder named "generic" and a log-file. The last 4 lines of the log-file can be seen below (I hope these are sufficient):

Lua module: luaotfload 2011/04/21 1.25 OpenType layout system.
luaotfload: loading file C:/Program Files/MiKTeX 2.9/tex/luatex/luaotfload/otfl
quiting: fix your readable cache path

If the moderators think this is important enough to post it as a separate question, I'm happy to do that. :D

  • 1
    Have you tried the miktex mailing list ? Commented Jun 28, 2011 at 6:07
  • 2
    Try to build the lualatex format manually: miktex settings, tab format, select lualatex and click on "build". Commented Jun 28, 2011 at 10:52
  • @Taco: No, actually I didn't, because I thought that this is a problem only I'm having, but I just looked at the list and thus solved my xfrac-problem (l3kernel was missing I think), so thank you for your hint.
    – Lustique
    Commented Jun 28, 2011 at 12:09
  • @Ulrike: I already tried that (looked at the MiKTeX mailing list again and found someone who seemingly got a solution for my problem (I think it was exactly what you wrote)), but unfortunately it didn't work for me. But thanks anyway!
    – Lustique
    Commented Jun 28, 2011 at 12:17
  • 1
    @Lustique. What does "it didn't work" mean? Did you get an error during the format generation? Do you have a multiuser installation? If yes: did you create the formats in user or admin mode? Btw: lualatex works fine for me. Regarding expl3: The latex3-files has been rearranged. expl3 and xpackages will be removed from miktex, the files are now in l3kernel and l3packages. Sync in the package manager (user + admin mode) the repositories to avoid confusion. Commented Jun 28, 2011 at 12:35

3 Answers 3


I wrote about this bug to the maintainer of MiKTeX about two weeks ago, but got no answer.

Thus I installed TeX Live 2010. If you know what you are doing, you can do this:

  1. Start the installation process of TeX Live 2010. Wait until it created all the folders. Abort the installation.
  2. Copy all the LaTeX packages and the respective documentation from MiKTeX to the corresponding folders of TeX Live.
  3. Start installation process again.
  4. Afterwards get the update of luatex from tlcontrib.
  • Is there no other way? I really like this "I'll do almost everything for you automatically"-approach of MiKTeX. Or is this also possible when using TeXLive (without too much of an effort, since I'm already rather challenged by using LaTeX/LuaLaTeX/XeLaTeX so I don't want a distribution that is also as complicated to maintain :o)?
    – Lustique
    Commented Jun 28, 2011 at 12:18
  • Because I, more or less, only once tried to change something by myself (add the ccicons package to my MiKTeX, because the provided version didn't work at all) and somehow wrecked the whole distribution this way; I'm actually rather averse to the idea of having to do more things myself.
    – Lustique
    Commented Jun 28, 2011 at 12:19

I encountered the same problem before. When I downloaded the latest unicode-math packages from GitHub, it worked fine. I don't understand the connection, and it may be specific to my computer, but you can give it a try.

  • It didn't work for me. :/
    – Lustique
    Commented Aug 7, 2011 at 10:25

I had the same problem with Miktex 2.9.

I use Windows 7.

I fixed it by setting an Environment variable named TEXMFCACHE which in my case to


It worked.

  • I am using WnEdt 8.0 in Wndows XP and I receive the same error. How can I modify my program to make it work?
    – bkarpuz
    Commented Nov 30, 2013 at 20:47
  • I have installed TeX Live 2010 and set in my compiler (WnEdt 8) the new path for the executable file (C:\Program Files\texlive\2013\bin\win32\lualatex.exe). Now it works.
    – bkarpuz
    Commented Dec 2, 2013 at 6:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .