26

I tried all methods from this question: How to change font family in footnote? and none of them work for me...

3 Answers 3

16

The command setting the desired size is \footnotesize. It can be used also outside footnotes, for text matching the size of footnotes. If that text should be treated different, it should not use \footnotesize, logically. So let's rely on consistent use.

The command \footnotesize does some more than changing the font size, it adjusts further śpace values such as in lists and around math formulas.

As default, beamer loads size11.clo, there \footnotesize is defined as:

\newcommand\footnotesize{%
   \@setfontsize\footnotesize\@ixpt{11}%
   \abovedisplayskip 8\p@ \@plus2\p@ \@minus4\p@
   \abovedisplayshortskip \z@ \@plus\p@
   \belowdisplayshortskip 4\p@ \@plus2\p@ \@minus2\p@
   \def\@listi{\leftmargin\leftmargini
               \topsep 4\p@ \@plus2\p@ \@minus2\p@
               \parsep 2\p@ \@plus\p@ \@minus\p@
               \itemsep \parsep}%
   \belowdisplayskip \abovedisplayskip
}

Just to let you know what's the orignal. You could redefine \footnotesize. You could even to that using the original, for keeping the spacing values:

\let\oldfootnotesize\footnotesize
\renewcommand*{\footnotesize}{\oldfootnotesize\tiny}

Instead of the simple example \tiny you could use an arbitrary size by \fontsize{...}{...}\selectfont.

45

The "official" method to change the \footnote font size is a call to \setbeamerfont applied to the footnote beamer font.

Example:

\setbeamerfont{footnote}{size=\tiny}

Default is:

\setbeamerfont{footnote}{size=\footnotesize}

A complete example:

\documentclass{beamer}

\begin{document}
\begin{frame}
  Text \footnote{First footnote}

  \setbeamerfont{footnote}{size=\tiny}
  Text \footnote{Second footnote}

  \setbeamerfont{footnote}{size=\footnotesize}
  Text \footnote{Third footnote}

\end{frame}
\end{document}
4
  • Unfortunately, this doesn't work if french option of babel is used. Mar 9, 2016 at 20:52
  • @DenisBitouzé With french option of babel, \setbeamertemplate{footnote}... and \setbeamerfont{footnote}... don't work. It's like a bug in babel-french... Mar 10, 2016 at 6:41
  • 1
    @DenisBitouzé You may use \frenchbsetup{FrenchFootnotes=false} as a workaround... Mar 10, 2016 at 7:05
  • 1
    \frenchbsetup{FrenchFootnotes=false} is indeed only a workaround: you loose the nice way French footnotes are displayed. Bug reported to babel-french's author. Mar 10, 2016 at 8:58
6

If you only want to change the footnote text size for a single footnote, as one occasionally has to do when citing long URLs, the graphicx package loaded with

\usepackage{graphicx}

provides the \scalebox{<scale>}{<text>} command, where <scale> denotes the ratio of the new size to the original size. For example:

The StackExchange website provides an almost infinite amount of \LaTeX\ wisdom!%
\footnote{\scalebox{0.8}{%
  \url{http://tex.stackexchange.com/questions/21741/how-do-i-change-footnote-font-size-in-beamer-presentation}%
}} 

The footnote in this example would be set to 80% of the normal size.

1
  • Do you happen to know how to change the numbers in before the footnotes text? I use your method, but the number 1, 2, 3 before footnotes are still a little bit big. Sep 10, 2021 at 19:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .