2

I want to put the title in italic, but it only prints out the author in italic. So I forced everything into normal text with this>

\addcontentsline{toc}{chapter}{Bibliography}
\begingroup
\let\itshape\upshape
\bibliographystyle{unsrt}
\bibliography{mybib}
\endgroup

But I want to put the title of the article in italic:

A minimum example should be:

Laszlo Tabar, Ming-Fang Yen, Bedrich Vitak, Hsiu-Hsi Tony Chen, Robert A Smith, and Stephen W Duy. "Mammography service screening and mortality in breast cancer patients: 20-year follow-up before and after introduction of screening". The Lancet, 361(9367):1405{1410, April 2003.

I want to put:

"Mammography service screening and mortality in breast cancer patients: 20-year follow-up before and after introduction of screening"

in italic like this:

"Mammography service screening and mortality in breast cancer patients: 20-year follow-up before and after introduction of screening"

  • 1
    Hi and welcome, we need a bit more information to be helpful here. – Johannes_B Dec 11 '14 at 9:44
  • 1
    Welcome to TeX.SX! You should post a minimal working example (MWE). In a standard document the title is italic not the author. – Andrew Swann Dec 11 '14 at 9:45
  • 1
    I recommend using the modern biblatex along with biber. Changing the appearance of the bibliography using the old system is cruel. – Johannes_B Dec 11 '14 at 9:45
  • Johannes_B and Andrew Swann I already put a minimum example. – André Monteiro Dec 11 '14 at 13:05
  • If you disable \itshape, you can't have italics. Are you sure the style prints the names in italics? It doesn't, according to my experience. – egreg Dec 11 '14 at 13:55
1

The question really doesn't give enough information to provide a definitive answer, but some things can be offered. Some comments suggest using a different bibliography program. But if you wish to remain with bibtex, you can make a copy of the bibliography style (.bst file). In this case, I rename unsrt.bst to myunsrt.bst.

Programming in BST language is arcane, but in the case of making something, italic, it amounts to adding the word emphasize following the field. So, if the item in question is an @ARTICLE, then I edit the definition to add the word emphasize following format.title, as such:

FUNCTION {article}
{ output.bibitem
  format.authors "author" output.check
  new.block
  format.title emphasize "title" output.check
  new.block
  crossref missing$
    { journal emphasize "journal" output.check
      format.vol.num.pages output
      format.date "year" output.check
    }
    { format.article.crossref output.nonnull
      format.pages output
    }
  if$
  new.block
  note output
  fin.entry
}

Then, when I run the program

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents}{mybib.bib}

@ARTICLE{myref,
  AUTHOR = "last, first",
  TITLE = "This is the title",
  JOURNAL = "The Lancet",
  YEAR = "2014"
}
\end{filecontents}
\bibliographystyle{myunsrt}
\begin{document}
I will cite \cite{myref}
\bibliography{mybib}
\end{document}

I get the following output, with the title emphasized (italic in this case):

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.