1

I'm working with classicthesis in LYX. How to put unnumbered chapter Appendix properly aligned with the rest of ToC? Additionally unnumbered title is the one who has no dots to indicate the page. How can I put well aligned and dots?

\chapter*{Appendix: Is there Economic Growth dependence on fossil-fuel Consumption?:
Nonlinear deterministic convergence analysis.}




\addcontentsline{toc}{chapter}{Appendix: Is there Economic Growth dependence on fossil-fuel Consumption?: Nonlinear deterministic convergence analysis}




\chaptermark{Dependence on fossil-fuel Consumption?}

ToC looklike

  • 1
    Use short description and section like \addcontentsline{toc}{section}{Appendix: Economic Growth dependence -- Nonlinear deterministic convergence analysis.} For chapter there are no dots! – user11232 Dec 11 '14 at 14:00
  • Welcome to TeX.SX! You have to me more precise. What is well aligned for you. Like it stands, the two chapters "4" and "Appendix" are perfectly aligned. Please give us an MWE which we can copy and compile and explain, what you really need. The title is much too long, where should the points appear? – LaRiFaRi Dec 11 '14 at 14:03
  • Hi and welcome, use \addchap{Appendix: Economic Growth dependence -- Nonlinear deterministic convergence analysis.} and set the gloabel option toc=numberline. Of course, this will only work, if you are using a KOMA-class or package unnumberedtotoc – Johannes_B Dec 11 '14 at 14:20
1

Assuming a very basic setup based on KOMA-script we can use addchap to get unnumbered chapters along with an entry in the table of contents. Indenting all those unnumbered entries can easily be done with one little switch.

Adding dots to the chapter entries can be done just as easy, unfortunately classicthesis loads packages incompatible with KOMA an hence breaking the documented interface. We have to use the stuff from tocloft to get dots for chapter entries.

guandiClassicthesisTocStuff

\documentclass[headinclude=true,footinclude=true]{scrreprt}

\usepackage[dottedtoc]{classicthesis}
\KOMAoptions{toc=indentunnumbered,
chapterentrydots=true%<---- This works if KOMA is not overridden
}

\renewcommand{\cftchapleader}{\cftdotfill{\cftchapdotsep}}
\renewcommand{\cftchapdotsep}{\cftdotsep}

\hypersetup{hidelinks}
\begin{document}

\tableofcontents
\chapter{Rock and Roll Racoon}
\section{defining the dance}
\appendix
\addchap{Rumba Rhinoceros}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.